Build 1.2 ISO with custom packages from backports



Following the build instructions for 1.2 I was able to add a few packages to test building our own iso. What I can’t figure out is how to include packages from jessie-backports.

For instance I was trying to include nginx to act as a reverse proxy and ssl termination point. If I just pass nginx to ./configure --custom-packages="nginx htop" it does indeed add the package, but from the main repo. I really want to get an updated version of nginx as it includes features like udp load balancing too.

root@debian-jessie:~# apt-cache -t jessie-backports show nginx | grep -A 1 "Package: nginx"
Package: nginx
Version: 1.10.3-1+deb9u1~bpo8+2
Package: nginx
Version: 1.6.2-5+deb8u5

I’ve only seen a few posts talk about this related topic and one even mentions they don’t know how to get packages from backports.

What I still missed to find out is how to make the build system install the “firmware-atheros” package from jessie-backports…

Secondly, As I understand it so far /config is really the only directory where things are persisted between image upgrades. How would I go about moving my nginx configs /etc/nginx here and stay through an upgrade?


Figured out my own answer for anyone who comes across this. I found a Debian bug report referencing using a backport using the live-build tool. The correct syntax you need is this:

./configure --custom-packages="nginx/jessie-backports htop"

I now get the newer version of nginx in my iso.

Now to figure out how to modify the config locations during the build.


I tried to update the wiki page to reflect this option as well, but the wiki denied my change:
Forbidden: Contains contacts

=== Adding Custom Packages ===

You can add custom packages with the --custom-packages= option, e.g.
./configure --custom-packages="nginx"
If you want to include packages from backports repo specify it like this, e.g.
./configure --custom-packages="nginx/jessie-backports"



This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.