Certificate issue - downloads.vyos.io

This server could not prove that it is downloads.vyos.io; its security certificate is from *.dnsmadeeasy.com. This may be caused by a misconfiguration or an attacker intercepting your connection.

SAN
DNS Name=*.dnsmadeeasy.com
DNS Name=dnsmadeeasy.com

Looks like a dns/cert issue on the download site.

The old download site is deprecated. Please use vyos.net/get where the old site redirects to. Despite the cert warning

Is there an equivalent of this URL still in existence?

https://downloads.vyos.io/rolling/current/amd64/vyos-rolling-latest.iso

I used a little script on my router to pull the latest iso and apply it.

#!/bin/vbash

# printf '%s\n' "Yes" "" "Yes" "Yes" | /opt/vyatta/bin/vyatta-op-cmd-wrapper add system image https://downloads.vyos.io/rolling/current/amd64/vyos-rolling-latest.iso && reboot now
printf '%s\n' "Yes" "" "Yes" "Yes" | /opt/vyatta/bin/vyatta-op-cmd-wrapper add system image https://downloads.vyos.io/rolling/current/amd64/vyos-rolling-latest.iso

exit 0

1 Like

I did mention this in slack, but it’s not actually working.

I’ve had the same issue (scripting the update like the OP), didn’t realise the old URL had been deprecated.

I’ve tried this:
https://s3.amazonaws.com/s3-us.vyos.io/rolling/current/vyos-rolling-latest.iso

but it gets the XML error that xrobau posted above (which is the same error I get if I type garbage into that path, so presume a 404 rather than a permissions issue).

I’ll just change my script to check the downloads page for the latest URL for now.

As there is no longer a latest iso link could you share how you’re doing that please?

Sure, it’s possibly breaking all sorts of style and best practice rules but it’s working for me. By default it will just echo the URL (for testing), switch the command assignment if you want it to actually add the image.

#!/usr/bin/env python3

import requests
import re
import os

url = "https://vyos.net/get/nightly-builds/"
regex = r'\"(https:\/\/s3\.[^\"]*?\.iso)\"'

command = "echo This is the ISO URL: "
#command = "/opt/vyatta/bin/vyatta-op-cmd-wrapper add system image"

try:
    contents = requests.get(url)

    if contents:
        match = re.search(regex, contents.text, re.I)

        if match:
            os.system(command + " " + match.group(1))
        else:
            print("Error: Cannot find ISO URL")
    else:
        print("Error: Cannot retrieve web page")

except:
    print("Error: Unhandled exception");

I’m always reluctant to do anything that will scrape a web page, one reason is due to load on the site. But this is only going to be run once per update anyway, just as if I’d browsed to the page myself and copied the latest URL.

2 Likes

Many thanks for sharing.

@c-po

Could the URL pointing to the latest iso be reinstated?

Apparently they haven’t either since their documentation at the link below still shows that URL.

So what are we supposed to use now for the rolling release updates in place of what is show in the documentation??

https://docs.vyos.io/en/latest/installation/update.html

The latest releases are now available here:

https://vyos.net/get/nightly-builds/

This is probably not the best option and it might be worth making changes to publish links to the images.

Feel free to update the documentation.
It require a lot of improvements, updates and examples.

Valid point, but that aside, will a single standardised URL representing the latest rolling ISO be reinstated?

I hope so, it requires some time to integrate it.

Documentation changes done and pull request created.

2 Likes