How to pass SIP through nat with port and firewall


#1

Hi!

I am a newbie with vyOs I want to ask to pass phone server over the internet with port 5060.
here is my command

nat {
destination {
rule 10 {
destination {
address xxx.xxx.xxx.xxx (public IP)
port 5060-5080
}
inbound-interface eth1
protocol tcp_udp
translation {
address xxx.xxx.xxx.xxx (Private IP)
port 5060
}
}
}
source {
rule 10 {
outbound-interface eth1
protocol tcp_udp
source {
address xxx.xxx.xxx.xxx (Private IP)
port 5060
}
translation {
address xxx.xxx.xxx.xxx (public IP)
port 5060
}
}

Firewall:
rule 2 {
action accept
destination {
port 5060-5080
}
protocol tcp_udp
}

TIA


#2

Disable sip helper:
set system conntrack modules sip disable

SIP is port5060, I doubt RTP (=audio) is captured in 5060-5080 range


#3

I tried to disable sip helper. but still can’t reach the remote server. I’m using fushionpbx