How to use cloud-init?

Could somebody please point me to the right direction how could I bring up a WORKING and CONFIGURED VyOS VM in ANY local hypervisor – i.e. VMWare, Hyper-V, KVM, qemu – using cloud-init (i.e. WITHOUT any human typing things in console)?

I failed to find any useful documentation or forum question about the subject.

Things I tried so far:

  • Built latest rolling release from sources: has broken Hyper-V integration.

  • Built latest 1.3 release from sources: cloud-init gives several error messages during system startup, some things works, some don’t, but anyway is a dead-end since the image keeps saying I have to install it first (I’m booting a “live” image? What…?).

    • And install image cannot be run unattended

Images were built with make openstack. I tried to build hyper-v images (with make hyperv but it appears the build script is broken).

I have a little experience using both could-init and Vyatta based routers. But I don’t know what I’m doing wrong and I’m really tired of guessing things. I have lost several days now trying to make this work, without success.

Please, advice.