IPoE does not assign IPv6 PD or WAN address

Hi Friends,

I am using 1.3.0-rc1 and trying to setup an IPoE server:

set service ipoe-server authentication interface eth2 mac-address 00:AA:00:00:00:00    
set service ipoe-server authentication mode 'local'
set service ipoe-server name-server ''
set service ipoe-server name-server '2606:4700:4700::1111'
set service ipoe-server interface eth2 client-subnet ''
set service ipoe-server client-ipv6-pool delegate '2001:db8:1::/48' delegation-prefix '56'
set service ipoe-server client-ipv6-pool prefix '2001:db8:2::/48' mask '64'

it works perfectly with IPv4, but the IPv6 PD or WAN (/64) is never assigned. What i am missing ?

Thanks in advance,

BTW, i am using DHCP & DHCPv6 on the client.

Hello @marcomuskus, IPv6 can’t work without IPv4 configuration for IPoE service.

Yes, i am aware of that, however it doesn’t receive an IPv6 WAN or PD on the interface.

I mean, if i execute a DHCP client ($ sudo dhclient ethN) in linux it gets the IPv4, and after that i run an dhclient -6 ethN on the same interface it still doesn’t get any IP or response.

Hello @marcomuskus, really a very odd situation. IPoE daemon can not send the packet, because there is no link-local address on the interface ipoeX. Could you try manually add LL and run dhclient -6 again

sudo ip addr add fe80::5200:ff:fe0d:1/64 dev ipoe0
1 Like

Hi, i just set the Link-Local (LL) address in the ipoe0 interface and now is working correctly. The WAN gets an IPv6 and the PD in handled to the LAN.

Thank you so much @Dmitry !

Now, the question is: should i file/report this as a bug?

Absolutely. @marcomuskus please create a bug report on the phabricator.

1 Like

bug report created:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.