Migration error from vyos 1.4 april to the latest release 1.4 sep

Apologies, @tomcat667 , it seems like we are revisiting the problem from the first node, before using the simpler fix of using original files, and making the one line change of ‘–reflink=never’. We never found the reason for that odd error. The file you list as ‘after migration’ has our first fix, but the solution to the problem on the first node was to restore the original files and use the simpler fix.

Granted this is somewhat confusing to debug remotely. Let us verify: what I call the ‘simpler fix’ (relflink option) with the restored original files worked on the first node, yes ?

Okay, ignore the comment re ‘after migration’; that makes sense. Can you explain what you mean by the file from the first node being very strange ?

i will hold my request here, we have commissioned a corporate contract for vyos.
then I can send you my config files

After discussing with vyos support, i used following version 1.4-rolling-202310030309
but the installation of this version doesn´t work, failed with the same error.
Then we will reinstall this node but the installer is smart.

After rebooting the vyos and starting the installer from version 1.4-rolling-202310030309.
The installer found a vyos installation and ask me to keep the ssh keys and config. I agreed this. Finished the installation. Reboot after the installation
Migration of the config file run smooth trough.
Now all works as as expected.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.