Moving VyOS virtual machine between hosts - lost eth configuration


#1

Hi All,

I have installed and configured VyOS as a VM on my Hyper-V host. It had configured firewall rules and Nat rules on 2 ethernet interfaces eth0 and eth1.

I have made a live migration of this VM between hosts, and now after rebooting this VM i lost configuration for my ethernet interfaces.

Command show interfaces now results with eth2 and eth3 interfaces without any configurations there.

How to “repair” this, and how to prevent this occure in future when moving running VyOS machine between host in a pool.

regards,
Marcin


#2

Hello,
i think you need to remove hw-id on interfaces.
Hyper-V changing MACs if you migrate to other host??


#3

In HyperV, set the NIC to static MAC address (use old MAC address, or current hw-id if you already changed that).
This way, on next live-migrate, NICs will keep their addresses , and VyOS will not notice being migrated.


#4

Hi Marcin,

Have you solved your problem?

I am having the same issue, but the only difference is I am trying to migrate .ova vm on vmware from one host to another, when i start the migrated VM, it seems trying to load the configuration, but all configurations are failing. I tried to change MAC on esxi host same as it was in configuration file of VM. Still no luck

Feedback is much appreciated.


#5

Before set vm as template

delete interface eth0 hw-id
delete interface eth1 hw-id


#6

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.