Nic Ports Not Detected


#1

Hello team,

I installed a VyOS 1.1.8 a Dell R640, but the SO didn’t detect the onboard 10GbE interfaces.

Ps.: The ethernet controller is Intel® 10GbE 4P X710 rNDC. There’s no GBIC or cable connected.

Could you help with this issue?

DRIVER:

modinfo i40e

filename: /lib/modules/3.13.11-1-amd64-vyos/kernel/drivers/net/ethernet/intel/i40e/i40e.ko
version: 0.3.11-k
license: GPL
description: Intel® Ethernet Connection XL710 Network Driver
author: Intel Corporation, e1000-devel@lists.sourceforge.net
srcversion: AA74E009A27150EC747A138
alias: pci:v00008086d00001585svsdbcsci*
alias: pci:v00008086d00001584svsdbcsci*
alias: pci:v00008086d00001583svsdbcsci*
alias: pci:v00008086d00001582svsdbcsci*
alias: pci:v00008086d00001581svsdbcsci*
alias: pci:v00008086d00001580svsdbcsci*
alias: pci:v00008086d0000157Fsvsdbcsci*
alias: pci:v00008086d00001574svsdbcsci*
alias: pci:v00008086d00001573svsdbcsci*
alias: pci:v00008086d00001572svsdbcsci*
depends:
intree: Y
vermagic: 3.13.11-1-amd64-vyos SMP mod_unload modversions
parm: debug:Debug level (0=none,…,16=all) (int)

LOGS:

lspci -nn | grep Ethernet
19:00.0 Ethernet controller [0200]: Intel Corporation Device [8086:1572] (rev 01)
19:00.1 Ethernet controller [0200]: Intel Corporation Device [8086:1572] (rev 01)
19:00.2 Ethernet controller [0200]: Intel Corporation Device [8086:1572] (rev 01)
19:00.3 Ethernet controller [0200]: Intel Corporation Device [8086:1572] (rev 01)
3b:00.0 Ethernet controller [0200]: Intel Corporation Device [8086:1521] (rev 01)
3b:00.1 Ethernet controller [0200]: Intel Corporation Device [8086:1521] (rev 01)

ls -l /sys/class/net/
lrwxrwxrwx 1 root root 0 Jan 7 20:31 eth4 -> …/…/devices/pci0000:3a/0000:3a:00.0/0000:3b:00.1/net/eth4
lrwxrwxrwx 1 root root 0 Jan 7 20:31 eth5 -> …/…/devices/pci0000:3a/0000:3a:00.0/0000:3b:00.0/net/eth5
lrwxrwxrwx 1 root root 0 Jan 7 20:31 lo -> …/…/devices/virtual/net/lo

dmesg | grep 0000:19

[ 1.223763] pci 0000:19:00.0: [8086:1572] type 00 class 0x020000

[ 1.223783] pci 0000:19:00.0: reg 0x10: [mem 0xa1000000-0xa1ffffff 64bit pref]

[ 1.223809] pci 0000:19:00.0: reg 0x1c: [mem 0xa2018000-0xa201ffff 64bit pref]

[ 1.223829] pci 0000:19:00.0: reg 0x30: [mem 0xfff80000-0xffffffff pref]

[ 1.223886] pci 0000:19:00.0: PME# supported from D0 D3hot D3cold

[ 1.224072] pci 0000:19:00.1: [8086:1572] type 00 class 0x020000

[ 1.224092] pci 0000:19:00.1: reg 0x10: [mem 0xa0000000-0xa0ffffff 64bit pref]

[ 1.224117] pci 0000:19:00.1: reg 0x1c: [mem 0xa2010000-0xa2017fff 64bit pref]

[ 1.224137] pci 0000:19:00.1: reg 0x30: [mem 0xfff80000-0xffffffff pref]

[ 1.224194] pci 0000:19:00.1: PME# supported from D0 D3hot D3cold

[ 1.224369] pci 0000:19:00.2: [8086:1572] type 00 class 0x020000

[ 1.224389] pci 0000:19:00.2: reg 0x10: [mem 0x9f000000-0x9fffffff 64bit pref]

[ 1.224414] pci 0000:19:00.2: reg 0x1c: [mem 0xa2008000-0xa200ffff 64bit pref]

[ 1.224434] pci 0000:19:00.2: reg 0x30: [mem 0xfff80000-0xffffffff pref]

[ 1.224491] pci 0000:19:00.2: PME# supported from D0 D3hot D3cold

[ 1.224665] pci 0000:19:00.3: [8086:1572] type 00 class 0x020000

[ 1.224685] pci 0000:19:00.3: reg 0x10: [mem 0x9e000000-0x9effffff 64bit pref]

[ 1.224710] pci 0000:19:00.3: reg 0x1c: [mem 0xa2000000-0xa2007fff 64bit pref]

[ 1.224730] pci 0000:19:00.3: reg 0x30: [mem 0xfff80000-0xffffffff pref]

[ 1.224787] pci 0000:19:00.3: PME# supported from D0 D3hot D3cold

[ 1.338061] pci 0000:19:00.0: no compatible bridge window for [mem 0xfff80000-0xffffffff pref]

[ 1.338063] pci 0000:19:00.1: no compatible bridge window for [mem 0xfff80000-0xffffffff pref]

[ 1.338065] pci 0000:19:00.2: no compatible bridge window for [mem 0xfff80000-0xffffffff pref]

[ 1.338066] pci 0000:19:00.3: no compatible bridge window for [mem 0xfff80000-0xffffffff pref]

[ 1.338211] pci 0000:19:00.0: BAR 6: assigned [mem 0xa2080000-0xa20fffff pref]

[ 1.338213] pci 0000:19:00.1: BAR 6: assigned [mem 0x9d900000-0x9d97ffff pref]

[ 1.338214] pci 0000:19:00.2: BAR 6: assigned [mem 0x9d980000-0x9d9fffff pref]

[ 1.338216] pci 0000:19:00.3: BAR 6: assigned [mem 0x9da00000-0x9da7ffff pref]

[ 1.338235] pci_bus 0000:19: resource 1 [mem 0x9d900000-0x9dafffff]

[ 1.338237] pci_bus 0000:19: resource 2 [mem 0x9e000000-0xa20fffff 64bit pref]

[ 1.650262] pci 0000:19:00.0: Signaling PME through PCIe PME interrupt

[ 1.650265] pci 0000:19:00.1: Signaling PME through PCIe PME interrupt

[ 1.650269] pci 0000:19:00.2: Signaling PME through PCIe PME interrupt

[ 1.650273] pci 0000:19:00.3: Signaling PME through PCIe PME interrupt

[ 2.951472] i40e 0000:19:00.0: f6.80 a1.7 n00.00.00 e00000000

[ 2.951478] i40e 0000:19:00.0: init_adminq failed: -65 expecting API 01.00

[ 2.951645] i40e: probe of 0000:19:00.0 failed with error -65

[ 2.971453] i40e 0000:19:00.1: f6.80 a1.7 n00.00.00 e00000000

[ 2.971454] i40e 0000:19:00.1: init_adminq failed: -65 expecting API 01.00

[ 2.971721] i40e: probe of 0000:19:00.1 failed with error -65

[ 2.992449] i40e 0000:19:00.2: f6.80 a1.7 n00.00.00 e00000000

[ 2.992450] i40e 0000:19:00.2: init_adminq failed: -65 expecting API 01.00

[ 2.992731] i40e: probe of 0000:19:00.2 failed with error -65

[ 3.013392] i40e 0000:19:00.3: Initial pf_reset failed: -15

[ 3.013623] i40e: probe of 0000:19:00.3 failed with error -15


#2

VyOS 1.1.8 is EOL and has no driver support for this NIC. Please upgrade to VyOS 1.2.0 rc/EPA or any rollig release version


#4

Hi!

Thanks for the answer.

One doubt: Vyos 1.2 is already stable?