Problem user disonnecting in pppoe server

Dear sir,

i am using vyos as has some issues . I couldn’t fine any option as keepalive timeout. because vyos takes 3 mins time to disconnecting user even it has power frailer

Arun Tamrakar
Pokhara Nepal

Perhaps this command will help you?
set interfaces pppoe <interface> idle-timeout <time>

thanks for reply . this is not my solution , i am working on pppoe-server so, all the client that connected with the pppoe-server they are not disconnecting for 3 mins even clients has power frailer and cable disconnect . As you sent configuration is not found in pppoe-serve it found only pppoe-clinet ( dialup ). i wants know is there any option as keepalive timeout in vyos ?

Best Regards,

Do you use radius for pppoe sessions?

yes i use it radius for pppoe session

@linuxpkr hi, check the following hierarchy and options:

set service pppoe-server ppp-options
Possible completions:
   ccp          CCP negotiation (default disabled)
                PPP interface cache
   ipv4         IPv4 (IPCP) negotiation algorithm
   ipv6         IPv6 (IPCP6) negotiation algorithm
                Accept peer interface identifier
   ipv6-intf-id Fixed or random interface identifier for IPv6
                Peer interface identifier for IPv6
                Maximum number of Echo-Requests may be sent without valid reply
                LCP echo-requests/sec
                Timeout in seconds to wait for any peer activity. If this option specified it turns on adaptive lcp echo functionality and "lcp-echo-failure" is not used.
   min-mtu      Minimum acceptable MTU (68-65535)
   mppe         Specifies mppe negotiation preferences
   mru          Preferred MRU (68-65535)

I think you need to tune lcp-echo-timeout

thanks it works … it has another issues …i am using DMA radius manager and i choose NAS = others . but it not accepting the radius server rules. not expires any clients and doesn’t disconnect that clients manually disconnected from radius manager task

Arun tamrakar