Replacing Mikrotik BW Limiter into VyOS

Hello. We have a plan to replace our Mikrotik device into VyOS. Right now the function of the Mikrotik Device is for Traffic Limiter using IP Based Queues in Mikrotik. The queue are graphed into Cacti so our customer can view the bandwidth usage of their services. It is possible to achieve this scenario with VyOS ?

Thankyou.

PS : Graphing queue in Cacti is a must for us.

Hello, @harajukakei!
I believe that it is possible to configure queues. But “graphs” part is not very clear. Can you provide an example of such graphs? Also, if you provide queues configuration from MikroTik (export from CLI), we will be able to give you some advises about queue configuration.

Do you have multiple queues (1 per IP)?
As I understand it, each queue is unique in Mikrotik and has its own SNMP-OID.
Cacti get this information via snmp.

this is the queue that we create in Mikrotik :

/queue simple
add bucket-size=0.1/0.1 burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s \
    disabled=no limit-at=0/0 max-limit=20M/20M name=*** packet-marks="" parent=\
    none priority=8/8 queue=default-small/default-small target=\
    X.X.X.X/30,X.X.X.X/24 !time
add bucket-size=0.1/0.1 burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s \
    disabled=no limit-at=0/0 max-limit=100M/100M name=*** packet-marks="" \
    parent=none priority=8/8 queue=default-small/default-small target=\
    X.X.X.X/30,X.X.X.X/30 !time
add bucket-size=0.1/0.1 burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s \
    disabled=no limit-at=0/0 max-limit=100M/100M name=\
    "***" packet-marks="" parent=none priority=8/8 \
    queue=default-small/default-small target=X.X.X.X/30 !time
add bucket-size=0.1/0.1 burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s \
    disabled=no limit-at=0/0 max-limit=100M/100M name=*** packet-marks="" parent=none priority=8/8 queue=\
    default-small/default-small target="X.X.X.X/30,X.X.X.X/29,X.X.X.X/30,X.X.X.X/29,X.X.X.X/29,X.X.X.X/30,X.X.X.X\
    /29,2X.X.X.X/29,X.X.X.X2/28" !time
add bucket-size=0.1/0.1 burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s \
    disabled=no limit-at=0/0 max-limit=30M/30M name="***" \
    packet-marks="" parent=none priority=8/8 queue=default-small/default-small \
    target=X.X.X.X/27,X.X.X.X/27 !time
add bucket-size=0.1/0.1 burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s \
    disabled=no limit-at=0/0 max-limit=20M/20M name="***" \
    packet-marks="" parent=none priority=8/8 queue=default-small/default-small \
    target=X.X.X.X/30 !time

All x.x.x.x above is network address that different form one to others.

what i mean about graph is I can get a traffic graph using SNMP that captured into Cacti. So the user can monitor thw bandwidth usage in Cacti. If we using Mikrotik, Cacti can self discover all OID and related stuff about every queue that we created. how we achieve this in VyOS ?

Right, we have a lot of queue. In every queue that maybe one IP or network or multiple IP multiple network that targeted with thw queues.

@zsdc The VyOS don’t support this feauture natively.
As an option, I see using snmp-extensions with custom scripts.
https://vyos.readthedocs.io/en/latest/services/snmp.html#snmp-extensions

With
show interfaces ethernet eth1 queue class

Or something like
tc -s -d qdisc show dev eth1
tc -s -d class show dev eth1

Well, yes. You can configure queues, but there is no OID autogeneration for them. But, this is Linux and integrating something like GitHub - mum4k/tc_reader: A persistent SNMP script that exports TC Queue and Class statistics for graphing (for example to Cacti). should not be a problem.