Vyos + apu2 not hitting 1gb/s

Mitigations removed I am near as damn it line speed.

910 down / 720 up

Can live with that for sure. See screenshots for top values. I assume they are looking as expected?

How do I sustain this? I have a custom grub.cfg file which I assume will be overwritten on updates and also the hardware interrupts file has been modified.

I am desperate to retire my edge devices as UI stopped caring about these some time back.

Hello @phillipmcmahon, I propose to create a feature request to disable mitigation from CLI. Please describe a feature request on the https://phabricator.vyos.net/

Yes. It looks pretty.

One more thing, I’m not 100% sure, but you can try to enable ntuple, maybe IRQ will work a bit better.

I can do yes, however can you explicitly state what exactly I should configure. Don’t want to get this wrong. :slight_smile:

Try to execute

sudo ethtool -K eth0 ntuple on
sudo ethtool -K eth2 ntuple on

Check it with command

sudo ethtool -k eth0 | grep ntuple
sudo ethtool -k eth2 | grep ntuple

On some Intel NICs it adds more balancing.

Enabled those.

retested and get 980d/820u. This changes slightly with every run of course.

I assume this is something I need to add every time I do an image upgrade?

What would I need to put in the vyos-postconfig-bootup.script file to retain as much as possible?

Yes @phillipmcmahon, you right, just add

sudo ethtool -K eth0 ntuple on
sudo ethtool -K eth2 ntuple on

to vyos-postconfig-bootup.script and it would be migrated when VyOS version will be updated.

Great, done that.

Saw already that the igb-options.conf fix is already in the latest rolling version!

So pleased I can squeeze 1gb/s from the APU2, meaning I don’t have to reinstate my Edgerouter…

Thanks for the awesome support.


Just applied a new rolling release. Back down to 550-600 mb/s.

Seems similar to my original setup even though all changes are in place on my router. Sadly I deleted the previous image already so cannot roll back…

config.txt (4.3 KB) grub.cfg.txt (2.7 KB)
igb-options.conf.txt (32 Bytes)

Hello @phillipmcmahon,

Show me please an output cat /proc/cmdline and screenshot cat /proc/interrupts

Just performed another set of speed tests and the results are very inconsistent. Occasionally getting up to 900mb/s.

Output attached.

interrupts.txt (3.7 KB) cmdline.txt (194 Bytes)

I don’t see disabled mitigation on your booted cmdline

yet it is in my grub.cfg file…

As per the instructions on this thread

grub.cfg.txt (2.7 KB)

Try to update initramfs

sudo /usr/sbin/update-initramfs -u

And check after reboot /proc/cmdline again

yep, had done that a few times.

just did one more time, rebooted.

output of /proc/cmdline is still missing the entry

cat /proc/cmdline
BOOT_IMAGE=/boot/1.3-rolling-202010200146/vmlinuz boot=live quiet rootdelay=5 noautologin net.ifnames=0 biosdevname=0 vyos-union=/boot/1.3-rolling-202010200146 console=tty0 console=ttyS0,115200

Try to put this like an example, after boot=live:

menuentry "VyOS 1.3-rolling-202010200146 (KVM console)" {
        linux /boot/1.3-rolling-202010200146/vmlinuz boot=live mitigations=off quiet rootdelay=5 noautologin net.ifnames=0 biosdevname=0 vyos-union=/boot/1.3-rolling-202010200146 console=ttyS0,115200 console=tty0
        initrd /boot/1.3-rolling-202010200146/initrd.img
1 Like

yep, just did it like that and this time it is being picked up.

back in business! thanks a lot.

p.s. why previously did that work and now not?

I don’t have an answer, maybe something was different. I prefer always recheck cmdline after reboot or update.

thanks! appreciate the help. I should know what to look for in future.

@Dmitry There’s so much great info in this thread - hopefully it can be added to the Vyos wiki so that future users don’t have to search the forum to find it?
I certainly learnt a bit, I wasn’t aware about the ntuple feature.

Humm. It’s weird that you have to do all these configuration to get the 1gb full speed.

I use a lot of Mini PC Quad Core J1900 2GB RAM with 4 LAN Ports and I have no problem to get full gigabit speed with PPPoE.

Be sure that your LAN ports are Intel ones. With Realtek NIC I got problems and I was not able to get full gigabit speed with it.