VyOS device won’t get an IP address

I’m on a fresh VyOS 1.2.5 running on an older intel nuc (1.6ghz dual core celeron n3050).

The onboard nic gets detected as eth1

If I do a configure and set this for DHCP it gets an ipv6 address but not an ipv4 address. If I do tcpdump i do see network traffic including ARPs.

VyOS “show interface” also indicates the link is up.

The only suspicious thing I see is when I do “configure commit” there is an error message that says

Cannot get device pause settings: operation not permitted
Cannot change udp-fragmentation-offload

I’ve tried also setting a static IP address and I still can’t ping anything. I suspect it’s because no routes are being set. I tried using the Linux commands to manually set routes but I didn’t have much luck there either (but possibly my routes were wrong).

Any ideas on what my cause this?

Welcome to the Vyos forums :slight_smile:

Is nothing detected as eth0? It seems odd that eth1 would be the first interface detected.

What does

show hardware pci

Tell us?

Can you paste sanitised config of your Ethernet port setup? Does TCPDump see traffic in both directions? i.e. if you set a static IP and do pings, are you sending out ARP’s but not getting any replies, or do you see ARP replies? What does your show arp report?

And you’ve tried those simple things like changing cables etc?

It seems it’s rolling version.
show version

Hello @Ironman

You must indeed be using one of the latest rolling release. These messages are the result of some work to make sure any problems are now better reported to users. Unfortunately on the latest version, the reporting can be a bit overzealous … You can ignore the two “Cannot” lines, they are harmless and just reflect the capabilities of your underlying interface.

For the naming of the interface, there is little we can do the numbering is done by the OS and you can indeed have an external card taking precedence over a built-in one.

If the IPv6 address you see starts with fe80: then you are seeing a link-local IP and should ignore it. You will indeed need to configure both the IP and a default route.

Many people are using rolling in labs or even production when they need some features not available in the stable release. We are not aware of any issue with any of what you are trying.

All the information you need should be in our documentation. If you try a bit more it should just work :slight_smile:

I wish you a good continuation.

1 Like