Vyos ipv6 router-advert

ipv6
rad

#1

Hello!

I try to configure router advertisement for vyos like this:

set interfaces ethernet eth1 address ‘dead:beef:0:0:1::1/80’
set interfaces ethernet eth1 ipv6 dup-addr-detect-transmits ‘1’
set interfaces ethernet eth1 ipv6 router-advert cur-hop-limit ‘64’
set interfaces ethernet eth1 ipv6 router-advert link-mtu ‘0’
set interfaces ethernet eth1 ipv6 router-advert managed-flag ‘false’
set interfaces ethernet eth1 ipv6 router-advert max-interval ‘600’
set interfaces ethernet eth1 ipv6 router-advert other-config-flag ‘false’
set interfaces ethernet eth1 ipv6 router-advert prefix dead:beef:0:0:1::/80 autonomous-flag ‘true’
set interfaces ethernet eth1 ipv6 router-advert prefix dead:beef:0:0:1::/80 on-link-flag ‘true’
set interfaces ethernet eth1 ipv6 router-advert prefix dead:beef:0:0:1::/80 valid-lifetime ‘2592000’
set interfaces ethernet eth1 ipv6 router-advert reachable-time ‘0’
set interfaces ethernet eth1 ipv6 router-advert retrans-timer ‘0’
set interfaces ethernet eth1 ipv6 router-advert send-advert ‘true’

But it seems, that it does not work for mask like /80. But with /64 it works perfectly. The case, because I am doing it is that I want to share one /64 network to many smaller one.

Do anyone know what is the problem in my config?

Thank you in advice! Any help would be nice!


#2

Hi,

the advertisements are being sent with your config.
00:00:00.000000 IP6 (flowlabel 0xe46ff, hlim 255, next-header ICMPv6 (58) payload length: 56) fe80::a00:27ff:fe24:65ac > ip6-allnodes: [icmp6 sum ok] ICMP6, router advertisement, length 56
hop limit 64, Flags [none], pref medium, router lifetime 1800s, reachable time 0s, retrans time 0s
prefix info option (3), length 32 (4): dead:beef:0:0:1::/80, Flags [onlink, auto], valid time 2592000s, pref. time 604800s
0x0000: 50c0 0027 8d00 0009 3a80 0000 0000 dead
0x0010: beef 0000 0000 0001 0000 0000 0000
source link-address option (1), length 8 (1): 08:00:27:24:65:ac
0x0000: 0800 2724 65ac

Also your /80 is correctly advertised:

00:00:00.000000 IP6 (flowlabel 0xe46ff, hlim 255, next-header ICMPv6 (58) payload length: 56) fe80::a00:27ff:fe24:65ac > ip6-allnodes: [icmp6 sum ok] ICMP6, router advertisement, length 56
hop limit 64, Flags [none], pref medium, router lifetime 1800s, reachable time 0s, retrans time 0s
prefix info option (3), length 32 (4): dead:beef:0:0:1::/80, Flags [onlink, auto], valid time 2592000s, pref. time 604800s
0x0000: 50c0 0027 8d00 0009 3a80 0000 0000 dead
0x0010: beef 0000 0000 0001 0000 0000 0000
source link-address option (1), length 8 (1): 08:00:27:24:65:ac
0x0000: 0800 2724 65ac

I would expect an issue on your client side, remember that SLAAC only works on /64 or bigger.