VyOS lost entire BGP config

,

Dear community,

I am using VyOS version 1.3(default boot). In VyOS I have ~20-50 BGP sessions and everything was working perfectly. It was working for a long time, more than 12 months, with a lot of BGP config on it, and was rebooted multiple times. Recently I was working on one of the routers, doing kind of maintenance, and made some changes with commit-confirmed, lost access and the box rebooted. Once it came up, I noticed that everything related to BGP, entire hierarchy of “bgp 65000” was simply removed from the config. I looked into /config/config.boot, and it was missing from there as well… when I was trying to issue “show ip bgp” it was telling me that bgp subsystem is not running…
I looked at FRR service, and it was “inactive”…
I looked into the rollbacks, and found the following line:
#compare
0 2022-11-5 10:26:18 andrew by cli
1 2022-11-5 10:25:59 andrew by cli
2 2022-11-5 10:15:56 andrew by other → this is when it was rebooted…

To me it looks a little bit unclear, what was changed and who changed it ?!

I tried to rollback to that configuration but again, after the reboot, entire BGP configuration was missing…
I took it from the backup file, and entered all the BGP config as it was before, and… it worked, BGP started to work and all peers came up. Made another reboot, and it works just fine…

Can anybody tell what could be the root cause ? Did anybody run into similar issues in the past ?

One thing that I want to add is I am also using FRRs(bgpd daemon) to set descriptions on each BGP peer and then collect this information using zabbix-agent. I am doing this just because I already have a script that collect everything from FRR instead of VyOS but, peer’s description configured in VyOS doesn’t sync up with FRR… for some reasons…

Many thanks to anyone who can help with some ideas/suggestions/thoughts…

it shows you changes

compare 2

most likely bgp configuration was not committed properly, or you missed some warnings, raises and saved the config anyway.
for example, if you set peer without remote-as

set protocols bgp 64456 neighbor 192.0.2.22 description FooBAR
commit
save
reboot

as I remember it that case router could load without BGP at all
It is described at phabricator, I’ll send the link if I find

about descriptions, it was fixed it 1.4 but never backported to 1.3 T3184

@Viacheslav thank you very much for your reply.

Indeed, compare 2 shows like removal of entire BGP hierarchy and some route-maps.

I just want to confirm on the issue itselfe… SO, if I make a change on the VyOS BGP like the one you showed, it will commit the change but will raise up an “Warning”, but commit will still pass… Now, if I save config, on the next reboot it will load without BGP configuration at all ?

As about the peer description, thank you for pointing that, looking forward for an upgrade :slight_smile: