webproxy disable transparent not working also webproxy redirect url is not woking


#1

webproxy disable transparent not working also webproxy redirect url is not woking.

command:
set service webproxy url-filtering squidguard redirect-url https://www.google.com

command:
set service webproxy default-port 3128

command:
show service webproxy

result:

authentication {
children 5
credentials-ttl 60
}
cache-size 1024
default-port 3128
domain-block facebook.com
listen-address 10.0.0.1 {
disable-transparent
}
listen-address 172.16.0.1 {
disable-transparent
}
listen-address 192.168.0.1 {
disable-transparent
}
url-filtering {
squidguard {
auto-update {
update-hour 23
}
block-category ads
block-category malware
:

in windows 10 proxy settings

automatically detect settings off
use setup script off
use a proxy server off

So if disable-transparent is set it should block the urls and categories I have set automatically. But it is not blocking anything, but if I set

in windows 10 proxy settings

automatically detect settings off
use setup script off
use a proxy server on
address x.x.x.x port 3128

then it blocks urls and categories I have set. I want it to force me to set the proxy settings on all my workstations or,

set windows to automatically detect setting on

Even with windows set to automatically detect setting which is the default setting it still does not block the urls or categories I have set.

Please help


#2

I am having the same problem! Would someone please help. or is this a bug?


#3

you replied to your own thread stating you are having the same problem?

weird.

disable-transparent indeed turns off transparent proxy, and requires you to set a proxy setting in your browser. It appears to be working as intended.


#4

Sorry,

It was a copy and paste from another post.