1.2.2 or rolling - edit or set with question mark at config top level results in error

I’ve successfully built my own VyOS 1.2.2 ISO and installed on Hyper-V on Windows Server 2019. I’ve found that if I go into configure mode and try to use the set or edit commands with a question mark to get all available options at the top level, it results in the following error:

DEBUG vexit_internal: get_parsed_tmpl: failed to parse tmpl [/config]
DEBUG vexit_internal: get_parsed_tmpl: failed to parse tmpl [/config]

Must specify config path
Must specify config path
Must specify command and at least one component

Configuration path: [_] is not valid


I also tried downloading the latest rolling release (vyos-1.2.0-rolling+201908040337-amd64.iso) and got the same result. Just to make sure I wasn’t forgetting how I used to use VyOS, I downloaded 1.1.8 and it worked as expected showing the top level configuration categories.

Is there something I’m missing? If this isn’t expected behavior, can anyone else confirm this happens to them as well? I can successfully set the configuration options providing I at least know the top level configuration name, like system, or interface, etc.

Thanks!

Hello @vabello, I think this issue was resolved https://phabricator.vyos.net/T1561

Thanks! If I rebuild a new ISO for 1.2.2 will this now work correctly or do I need to build the latest rolling release?

I think it will works for 1.2.2 but you can just rebuild vyatta-ravpn package.

I can confirm the problem is resolved. I rebuilt a new ISO and “upgraded” to it and it now behaves as expected.

Thanks again!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.