1.3 RC2 DHCP client bug CONFIRMED

I have a working configuration using 1.4 nightly build but, with 1.3 working it’s way to final, I would like to run 1.3 RC on my production router so as to keep it on something more stable. I’ve installed the 1.3 RC2 image, set it as the default image, and rebooted. Unfortunately, when the router comes up I have no WAN connection. My WAN port has no IP. I’ve tried to disable and re-enable the port and statically set the IP to no avail. I’m unsure what more to do as far as troubleshooting. It is not possible to take a 1.4 config and downgrade to 1.3 or is there something I’m missing? Thanks in advance for any assistance!

It can be tricky as the config you have in 1.4 isn’t necessarily valid anymore on 1.3. I had a similar problem, and solved it like this.

Enable debugging https://docs.vyos.io/en/equuleus/debugging.html and this feature “vyos-config-debug”.

This will let the router restart even with a messed up config file. Once in the system, go into config mode and load your config. Try and commit it and you should start seeing which parts of your config cause errors. Clean those items up until you are able to do a full load and commit and at least you know the syntax issues are removed. Reboot.

Hopefully, that should restore your access. If not then pop back here and let’s hope we can help you resolve that as well.

I can try to give that a try Phillip. Long time no chat btw. The odd thing is that Vyos says that it successfully loaded the config; no errors or missing config segments. Even more weird is that Vyos sees the connection to my upstream router. Show ip route gives me a:
S> 0.0.0.0/0 via 192.168.88.1, eth4. I just cannot get my eth4 to get a dhcp. I’ve even enabled eth5 which I don’t normally use and it cannot pick up a dhcp address either. If I revert to 1.4, no issues at all.

I even loaded the default config and pasted the contents of a “show configuration commands” output from 1.4 in. Everything commited just fine. I had to modify the static table commands though as they have changed between 1.3 and 1.4.

I thought I recognised that name! Hope you’re well. Another route could be trying from a basic config and slowing adding in sections at a time… Painful I know.

What’s your routing table in 1.3 with the 1.4 modded config?

Well I just tried a completely fresh config and only configured eth4 for dhcp. Still nothing. Starting to wonder if there is a dhcp bug in RC2.

I will spin an RC2 image up tomorrow morning and see if I have DHCP issues as well. Will let you know.

Will look forward to seeing what you find. I gotta believe it’s a dhcp issue at this point given the elementary config and the fact that the router still sees my uplink in the routing table and has it set as the default route. I just can’t ping it or get internet connectivity.

1.3 RC1 works like a charm with no dhcp issues or other shenanigans other than having to redo my tables. RC2 is broken from what I can see. I will try to reinstall and update from 1.3 RC1 to see if things work that way.

Just readded the 1.3 RC2 image via my working 1.3 RC1 installation. Rebooted the router and bam, no DHCP. At this point I am 100% certain RC2 DHCP client is broken big time. Only took my until 0130 my time to sort it out. Welcome any and all outside confirmation or refutation. Vyos team, let’s hope this is fixed for RC3.

I concur, just installed RC2 in esxi, most basic config and cannot get a DHCP lease.

Confirmed working on RC1 with the same config file. Definitely broken.

Couldn’t wait until tomorrow eh? If it makes you feel any better it is tomorrow here already where I’m at.

Well just had to take a peek… Quick to do in esxi and then fiddled around to make sure I wasn’t going crazy as couldn’t get it to work. Strange that such a fundamental bug would get into an RC.

Even stranger that I had this happen once before with a 1.2 nightly back in the day. Freaking tore my hair out then as well. Argh!

I’m really glad you posted this so I didn’t spend all night trying to figure it out myself.

I can confirm the same issue though, I upgraded from 1.3.0-rc1 to rc2 and was unable to get a dhcp lease for my WAN interface no matter what I tried.

Is rc2 released? Can you point me to the location.

https://vyos.net/get/snapshots/#vyos-1.3.0-rc1

https://vyos.net/get/snapshots/

The task for it. https://phabricator.vyos.net/T3428

Thanks, hopefully a quick fix.

Is there a set of regression tests you run on releases/RC etc, that look to cover the fundamentals of functionality before being made available? DHCP breaking on an RC might be something that should be caught way earlier in your labs.