2-Factor all the things (starting with SSH AuthenticationMethods)


#1

Not 100% sure if this is the right place to post, but I’ve run into a snag where I’d like to add 2-factor auth to SSH on my VyOS box. Generally this means running a version of OpenSSH >=6.2 or a backport with the same functionality. However, the underlying version of OpenSSH in Squeeze is showing its age (version 5.5.).

I tried selectively updating OpenSSH, though the number of tagalong libs and such fundamentally break VyOS (configuration, etc). Has anyone had experience or success in shoehorning a newer version of OpenSSH in their VyOS install?