Accel-ppp shaper not applying Vendor/Attr

Hello,

Using the commands rate-limit attribute and rate-limit vendor wont change/add the [shaper] section in the pppoe.conf file. Adding the shapper parameters manually works fine.

Ex:
vyos@vyos# set service pppoe-server authentication radius rate-limit attribute XXXXX
vyos@vyos# set service pppoe-server authentication radius rate-limit vendor XXXXX

Editing the file

/var/run/accel-pppd/pppoe.conf

Adding the lines:

[shaper]
vendor=Cisco
attr=Cisco-AVPair
up-limiter=htb
down-limiter=tbf

And restarting accel works fine.

Hello @Dienac,

Did you enable rate-limit?

set service pppoe-server authentication radius rate-limit enable

I see the correct config file when rate-limit enabled.

Hello Dmitry,

Yes. its enabled.

service {
pppoe-server {
access-concentrator RS_CYI_BRAS_SRV_001
authentication {
mode radius
radius {
dynamic-author {
key ****************
port 3799
server xxx.xxx.xxx.xxx
}
nas-identifier RS_CYI_BRAS_SRV_001
nas-ip-address xxx.xxx.xxx.xxx
rate-limit {
attribute Cisco-AVPair
enable
vendor Cisco
}

show version

Version: VyOS 1.3-rolling-202009280118
Release Train: equuleus

It wont apply the [shaper] at pppoe.conf, I have to do it manually but every change at pppoe service I lose it and have to do again.

I checked the latest rolling and I can see shaper vendor attributes

set service pppoe-server access-concentrator 'R1'
set service pppoe-server authentication mode 'radius'
set service pppoe-server authentication radius dynamic-author key 'fdsfsdfsdf'
set service pppoe-server authentication radius dynamic-author port '3838'
set service pppoe-server authentication radius dynamic-author server '100.64.0.2'
set service pppoe-server authentication radius nas-identifier 'R1'
set service pppoe-server authentication radius nas-ip-address '100.64.0.1'
set service pppoe-server authentication radius rate-limit attribute 'Cisco-AVPair'
set service pppoe-server authentication radius rate-limit enable
set service pppoe-server authentication radius rate-limit vendor 'Cisco'
set service pppoe-server authentication radius server 100.64.0.2 key 'FOO'
set service pppoe-server authentication radius server 100.64.0.3 key 'FOO1'
set service pppoe-server gateway-address '100.64.0.1'
set service pppoe-server interface eth1

My section shaper

[shaper]
verbose=1
attr=Cisco-AVPair
vendor=Cisco

[cli]
tcp=127.0.0.1:2001[edit]
vyos@r4-roll#
1 Like