Add vendor in Accel configuration

Hello,

In some countries Mikrotik is really popular and some cheap ISP management/RADIUS send Mikrotik rate limit only but without editing the pppoe.config the rate limit wont work.

Using the command: set service pppoe-server authentication radius-settings rate-limit attribute Mikrotik-Rate-Limit wont work all the time with some RADIUS servers.

Something like set service pppoe-server authentication radius-settings rate-limit vendor 'XXXXX’ would do the job.

I tested it adding the vendor to the pppoe.config and worked.

This is an export of my [shaper] section:

[shaper]
verbose=1
vendor=Mikrotik
attr=Mikrotik-Rate-Limit

Edit1: The Mikrotik Dictionary is installed.

Please open a feature request in phabricator.vyos.net, should be relativly easy to implement your request.
I created one for you: https://phabricator.vyos.net/T1452