ARPPING not working


#1

Hello

I’ve a VM in VMWare with VyOS version 3.13.11-1, this machine has 5 network interfaces, all in different networks. The problem I’m facing it’s that when I made a arpping from a linux box to the VyOS interface I have no answer. Ping work as expected, tryed to disable arp-filter and enable arp-accept and arp-announce without success.

address 192.168.61.1/24
description XXXXXX
duplex auto
hw-id 00:50:56:90:ae:9d
ip {
disable-arp-filter
enable-arp-accept
enable-arp-announce
}

Any advice on how to enable arpping?

Regards


#2

what if you tcpdump -ni ethX arp to see if the arp requests from arping are making it to the VyOS VM. You can also see if there are replies, OR replies on the wrong interface. This might help narrow down where the problem is.


#3

Hello everyone. Sorry for 2 years late reply but here’s the solution:

http://blog.michael.kuron-germany.de/2015/07/arp-and-multicast-packets-lost-with-openvpn-in-tap-mode/

Basically it appears you need to do this: brctl setageing br0 0

Or in VyOS “language”: set interfaces bridge br0 aging 0


#4

Actually, that’s not the right solution. It will make it a hub.

EDIT: Restarted VyOS and it’s working fine.


#5

Lol, thanks.