Backporting kernel modules


#1

Hello,

I have a system with Intel i210 Ethernet controllers “[8086:1533] (rev03)” from lspci -nn. They are not detected by VyOS.

I’d like to be able to use this as an opportunity to learn how to collaborate with the VyOS team. What would be the best way to go about this? Should I clone pkgs/linux-image, merge in the newest Intel drivers, and submit a pull request if the resulting package works on my system? Should I only cherry pick commits to get i210 working? Something else entirely?


#2

Could you do us a favor and try a unstable version of vyos ?
Please try an ALPHA version of the vyos port to debian wheezy:

http://packages.multi.eu/iso/wheezy-transit/

This image has a way more modern 3.x kernel and probably has support for these nics’s built in.
It has not been tested a lot. I wouldn’t use it on a production unit yet (although I have done so)

Please let us know what happens.


#3

This works for me. It also fixed a second issue where I was unable to install from a USB stick: the 1.0.1 installer would begin to boot but was unable to find its root partition; this one works fine. I suspect the USB is another driver issue, I worked around it with 1.0.1 by attaching a SATA CDROM to the system.

I do still need to chroot and configure mdadm then re-install GRUB ala this blog in order to boot from a software RAID 1; other than that everything worked perfectly with the livecd-1401301700-b0d3bd7-amd64.iso image.


#4

Thank you for testing !

Again, it’s far from tested production quality .
I had it running as my core ipv6 router for 2 weeks without problems.
Also an extra machine with an USB wifi interface that wouldn’t work with vyos 1.0.x version worked great with the new version.

Work in progress, but nice to hear positive results/feedback!


#5

If those patches apply cleanly, that could be a solution.

Although rather than supporting the ancient kernel, it’s probably better to spend time on migrating the 1.x.x family to userspace UnionFS for the config and overlayfs for the root filesystem, like Kim did in the wheezy-transit image.

I will try merging those changes, if you want to help, that would be great.


#6

Ah, good, I think this is what I was waiting for, i.e., a version of VyOS rebased on master rather than VC6.6 (it’s especially useful because the older 3.3 kernel hasn’t got the nifty NAT66 stuff I want). Now, could someone tell me how do I setup git to track the wheezy-transit branch? I need to recompile a few packages to apply my usual patchset for IPv6 PBR, etc.

Looking at my routers (running Vyatta 999.master.06050443), I notice they use overlayfs also for the config. What are the advantages of using unionfs-fuse instead?


#7

Overlayfs does not work correctly if there are multiple config sessions, saving does not work.
On unionfs-fuse it works correctly.

Kim


#8

Hi

I tryid to install this on a system with i354 Network Controllers, but it can’t boot on the latest CD Image, it just keeps restarting. it works in a virtual box, but not on any hardware that i could find.

/Holmgreen