BGP IPV6 problem

hi i have problem with IPV6 bgp peering. here is my config:
show protocols bgp 42xxxxx neighbor 2a02:xxxxxxxxxxxx
address-family {
ipv4-unicast {
prefix-list {
export ipv4-drop-out
import ipv4-drop-out
ipv6-unicast {
maximum-prefix 2000
soft-reconfiguration {
description “XXXX”
remote-as XXXXX

and bgp si in this state:

IPV6 peer still sending ipv4 prefixes… How can i configure this to ipv6 only?? Thank you for help.

Try it.

set protocols bgp xxxx parameters default no-ipv4-unicast 


ok, so i have ipv4 peers in this router too… does it work with this setting as well?

use the statement that Viacheslav gave you and take the address-family ipv4-unicast stanza out of your ipv6 only neighbor - that should fix this problem.

If your ipv4 neighbors have an address-family ipv4-unicast stanza in their config they will still exchange ipv4 routes - parameters default no-ipv4-unicast only affects the default, address-family ipv4-unicast overrides it