BGP neighbor activated only v6


Has anyone noticed the problem described here?

6.1 ipv6 bgp problem? | Community (

The code has not changed in vyos 1.2.2 through 1.3.2.
I have a similar situation and I had to change the code in order for the things to work as intended.

about the post , there are two problems , both relative with quagga . It shouldn’t affect current version , Could you describe which is your issues ? we’ve migrated to FRR, where many old problems are solved.

This is the issue I had and it was solved like this (cited from the link):

This is what I changed in to disable IPv4 for a neighbor that is activated with IPv6:

--- /opt/vyatta/sbin/ 2011-04-22 11:19:57.000000000 -0700
+++ /opt/vyatta/sbin/      2011-04-22 10:49:38.000000000 -0700
@@ -133,7 +133,7 @@
       del => undef,
   'protocols bgp var neighbor var address-family ipv6-unicast' => {
-      set => 'router bgp #3 ; address-family ipv6 ; neighbor #5 activate',
+      set => 'router bgp #3 ; no neighbor #5 activate ; address-family ipv6 ; neighbor #5 activate',
       del => 'router bgp #3 ; address-family ipv6 ; no neighbor #5 activate',
   'protocols bgp var neighbor var address-family ipv6-unicast allowas-in' => {

I prefer to specify IPv4 and IPv6 neighbors separately (addressed with their respective protocols) at this time due to some weird observed behavior with the next hop address on my Cisco routers. Tested through a couple set/delete neighbor cycles and a reboot without any issues.

My config looks like this:

 neighbor {
     password x
     remote-as 65000
     update-source lo
 neighbor 2001:0db8::1 {
     address-family {
         ipv6-unicast {
     password x
     remote-as 65000
     update-source lo

I would suggest just adding an "address-family ipv4-unicast" section to the config to allow for backwards config compatibility in new versions.

I had a v6 only neighbor in BGP.

any news on this topic?

this behavior should be solved using the command set protocols bgp <asn> parameters default no-ipv4-unicast , so if you only need ipv6 neighbors .it allows configured it alone without the ipv4.

I am not sure that is the solution, as I have both, a ipv4 (only) neighbor and a different one, a ipv6 (only) neighbor, I do not want to disable all together the v4 capability.

I’d doesn’t disable IPv4 peers
It disable default IPv4 family for any peer if not configured any address family
For example without it IPv6 will be in both IPv4 and IPv6 afi

indeed it does work. thank you.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.