Bonding on Vyos 1.1.7 seems to not work with Force10


#1

Hello,

I have VyOS installed on a machine with a network card with two 10G interfaces.
I am using also Force10 S4810. I have created bonding on the VyOS and LACP port-channel on the Force10. Initially it is working. But when I disable one of the interfaces, the router becomes unreachable. After enabling the interface, no change.
The reboot resolves the issue.
Have anyone experienced such an issue ?

It seems like I didn’t notice this bug in the previous versions, or probably I didn’t test them properly.

Vyos bonding config:

[quote]set interfaces bonding bond0 description ‘Uplink-SW1-SW2’
set interfaces bonding bond0 hash-policy ‘layer3+4’
set interfaces bonding bond0 mode ‘802.3ad’
set interfaces bonding bond0 mtu ‘9000’
set interfaces ethernet eth2 bond-group ‘bond0’
set interfaces ethernet eth3 bond-group ‘bond0’
[/quote]

Force10 config:

[quote]interface TenGigabitEthernet 0/16
description Router
no ip address
mtu 12000
!
port-channel-protocol LACP
port-channel 2 mode active
!
no shutdown[/quote]


#2

I think you should use hash-policy ‘layer2’ because LACP/802.3ad operates at the frame/ethernet/layer2 level
layer3 or layer3+4 would be for switches that don’t support LACP/etherchannel


#3

Hi,

are you using the two Force10 Switches as Stack or VLT (Virtual Link Trunk) ?

And l3128 is right, its layer 2+3 for your config


#4

Hi all,

I am using the switches in a VLT configuration. Also there is no change when i use ‘layer2’ or ‘layer3+4’. It turned out that the issue was resolved by enabling/disabling the PROMISC option on the network interfaces. Once i shutdown one of the interfaces in the bond - the bond itself stops working. Then enabling PROMISC mode on the bond resolves the issue, until a reboot is performed.


#5

Hello,
can you report this behaviour on http://phabricator.vyos.net

Thanks


#6

Hello ,

Do we know if this problem exist also in the latest versions ? I have the same config and im planning to go production this weekend but i didn’t setup yet the LACP .

Thanks