Bridge interfaces

wifi
wireless
bridge

#1

just wanted to bridging eth1 + wlan0,
trying to create bridge br0 but absolutely impossible …
What’s is problem with? it seemed to be simple, but every time
we get the message blah blah failed when trying to “set interfaces bridge br0” commit.
I just follow the instructions but it does not work.
I also tried to create using brctl command but after restart router it will disappear,lost.
How can I create a bridge?

vyos@router# commit
[ interfaces bridge br0 ]
add bridge failed: Operation not permitted
Cannot find device “br0”

[[interfaces bridge br0]] failed
Commit failed
[edit]
vyos@router#

thanks


#2

really no one can advise how to create a bridge interface, what’s the problem?

ps: only latest I try create dummy interface dum0,oops anew error message “RTNETLINK answers: Operation not permitted”

why is it forbidden, how can I continue?


#3

so I resolved it in a different way, edited directly /config/config.boot file, reboot router and everything worked, then I normally finished using config command… simple work for a few minutes.
Bridge work fine.

Thank you for the null answers on this dead forum…


#4

I’m sorry, I was away on vacation and not able to cater to your request personally. I will forego my vacations from now on to cater to your needs.

In all honesty, you gave no details about your configuration that failed…soooo.


#5

Hello, I understand your vacation, only I was just surprised that the thread visit many people, but no one ever tried to discus it.

Of course I have provided the configuration at the beginning.
I just wanted to create a bridge interface

vyos@router# set interfaces bridge br0
vyos@router# commit
[ interfaces bridge br0 ]
add bridge failed: Operation not permitted
Cannot find device “br0”

[[interfaces bridge br0]] failed
Commit failed
[edit]
vyos@router#

but this was not possible, I had to edit /config/config.boot and then everything worked.

bridge br0 {
address 192.168.1.1/24
aging 300
description LAN
hello-time 2
max-age 20
priority 0
stp false
}

I just wanted to know why the operation via config command is forbidden.


#6

No you didn’t. You literally only provided the ERROR message you got when trying to commit.

set interfaces bridge br0 address 192.168.1.1/24 would have worked to create the bridge.


#7

Hello, thank for reply…
I do not know how much more I should provide the configuration.
Of course, I tried to create an with IP address, but still reported a error.
Never mind, I already created it manually in config.boot and everything works correctly.

I think it is not a condition to give an ip address, it’s possible to create a blank interface and then configure it later.

thanks


#8

You could have included the exact commands you attempted to use. Your first post showed commit as the command you used and then the failure. You did not provide us with any other information. You will only be able to receive help if you provide information.


#9

Hello,
I really do not know what other information should I give you?
I think the command is sufficient
set interfaces bridge br0 address 192.168.1.1/24
what else is needed? I think that is exact command…

Additionally, obviously you do not read carefully because the bridge has long been working, I created manual editing config.boot and then I went through the editor command
next finalize next options bridge interface.

interfaces {
bridge br0 {
address 192.168.1.1/24
aging 300
description LAN
hello-time 2
max-age 20
priority 0
stp false
}

as I write before, work okay…


#10

Perhaps you would benefit from reading through this thread and our exchanges. I read everything just fine.

I asked for more information. You gave me “I TOLD YOU ALREADY!” when you hadn’t, and you didn’t provide more information, but maybe you would rather just argue, in which case, you can go elsewhere for that.


#11