Building ISO 1.5, issues with Mirror Configuration

I’m competely new to Linux and VyOS. I’ve been trying to build the ISO on either 1.3, 1.4 or 1.5 using the relevant Linux distro’s via WSL2. 1.5 I’ve gotten to here (I’m assuming this is the latest supported version).

I’m running a completely fresh Ubuntu 22.04 with only the tools installed for this script.

There doesn’t seem to be anything at the URL when I’m viewing it in a browser, absolutely bewildered why it’s even trying to hit it.

I’m sure it’s something easy, any advice is appreciated. Not sure what the mirror config or caching proxy is. I’ve tried googling, I can’t find much on it.

Any help is appreciated

Since the Docker build environment images were made, I’ve not tried to build VyOS without them. I’ve not had much luck getting them to work with Podman, but I did get docker-ce to install on WSL2 as a test a while ago:

And you should be able to continue through the docs from there.

I’d suggest you’re running into problems because you’re trying to build directly on Ubuntu, while the VyOS build process assumes it’s running on vanilla Debian 12.

One other thing I bumped into when playing with VyOS builds in WSL2: don’t try to build sources from the remapped Windows filesystem - debuild doesn’t like the way Windows handles permissions, so these will fail. Sources held on Linux-native filesystems (most things outside of the drive mappings in /mnt/) work fine. Make sure any git repos you’re working with are not on remapped paths.

Let me know if this helps or if you run into any difficulties with the process.

Thanks so much for this talmakion, I was following just above the docker part of that guide which is where I was getting stuck.

That makes a lot of sense vanilla Debian would be needed.

1 Like

i dont know if this is a issue with the error you have here.
But as a warning, running the build-scripts inside WSL2 i think could be an issue.
The reason for this is the filesystem running under the wsl2 “container”, running on other file-systems than ext*, btrfs* or other non native linux file-systems could create issues.

1 Like

Also, if you do not need any changes to the 1.5 iso a nightly snapshot of 1.5 could be downloaded here: VyOS Community instead of byuilding it yourself. these builds are automatically built by github actions and a build-state of new builds can be found here: Workflow runs · vyos/vyos-rolling-nightly-builds · GitHub

1 Like

Have got it working, thank you guys!