Cannot set PPPoE Username with . character

I’m trying to configure my PPPoE WAN connection, however my PPPoE username contains a period (e.g. and VyOS won’t allow me to set it. When I run:

set interfaces pppoe pppoe0 authentication user

I get the following:

Username is limited to alphanumerical characters, -, _, #, and @ with a total lenght of 128
Value validation failed
Set failed

I’ve tried surrounding the username with both single quotes & double quotes, neither has any effect. Out of desperation I manually added my username to the startup config, however on reboot VyOS failed to load the config so I had to revert to my backup copy.

I’m currently running version 1.4-rolling-202302110748

I’d rather be stuck with dialup for the rest of my life than try and get my ISP to change my PPPoE username, any thoughts on where to go next with this?

Fixed in ⚓ T4998 pppoe username validation too restrictive (regression)
Update to the latest rolling or any rolling after 20230212

My bad, should have tried that sooner. Thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.