can't login with new 1.0.5 image [SOLVED]


#1

I just installed the new 1.0.5 image. Now I can’t login. My previous user and password no longer works. I also tried vyos:vyos, but that doesn’t work either.

Anybody know what the new release might have set the user and password to?


#2

I’m getting the same issue when i trying to update from vyos 1.0.2 .


#3

OK, Has anyone upgraded to 1.0.5 and NOT had the the user and password changed to something unknown? This has me stuck because I can’t access the system. I’m looking at doing a complete reinstall if there isn’t a fix for this.


#4

If you reboot the router, in the Grub OS list there’s a password recovery option.

Hope it will help


#5

The grub entry says something about password reset for vyos 1.0.3. I tried it anyway, but it doesn’t set the password for 1.0.5.

If I boot back into 1.0.4 my old password works.

Just noticed that 1.1.0 had been released. Installed it, but it’s the same thing: can’t log in. Apparently the account name and password have been changed to something that nobody knows.

Looks like I’m stuck with 1.0.4 while I look into other firewall options. Too bad because I really liked Vyatta/Vyos.


#6

You may pass on the chat , some of the developers are there all week days; they surely will be able to help you.

https://webchat.freenode.net/?channels=#vyos


#7

In my case updating vyos to 1.1.0 fixed the problem with login .

Anyway i filled a bug with this login problem after updating vyos , http://bugzilla.vyos.net/show_bug.cgi?id=327


#8

Seems that the upgrade process missed copying part of the config file.

On the IRC channel they suggested checking the config.boot file for the new version. The config files are under /live/image/boot//live-rw/config/. So, for 1.1.0 the file is /live/image/boot/vyos-1.1.0/live-rw/config/config.boot. A diff against the config file for 1.0.4 showed that the new one was missing the “login” section. That’s where it has the user account information. I copied the config.boot from 1.0.4 over it and then set 1.1.0 to be the default boot image. Rebooted and I am now able to login.