Cant save config to remote sftp server

Hi All,

Am trying to do a simple task but it seems to fail with the following error:
save scp://username@
curl: (2) Failure establishing ssh session: -5, Unable to exchange encryption keys

From the router itself am able to ssh in to the remote SFTP server without any issues or warnings.

Version:          VyOS 1.3.0-rc6
Release Train:    equuleus

Built by:         Sentrium S.L.
Built on:         Sun 22 Aug 2021 15:37 UTC
Build UUID:       965518de-857d-4e61-ab09-381aadf24eb1
Build Commit ID:  75b37b28b2e9ab

Architecture:     x86_64
Boot via:         installed image
System type:      bare metal

Hardware vendor:  Dell Inc.
Hardware model:   PowerEdge R210 II

Trying another username gives me the same error. Ive cleared the ssh file “known hosts” and tried again…same error. What am i doing wrong?


Could be a bug from the early 1.3 days. Please upgrade to VyOS 1.3.2

Ahh i wil try that image …
Normally i was able to find the monthly snapshots… now i can only see nightly builds. Is this moved, hidden or stopped?

Other question regarding config backup: Why is the interface hardware address stored in the config? When i need to replace a device it overwrite its hardware address which causes issues.


VyOS 1.3.0 has entered LTS stadium which means prebuild binaries are no longer available publicly and need a subscription (e.g. OpenCollective). You are free to build the image on your own (see Build VyOS — VyOS 1.3.x (equuleus) documentation)

VyOS 1.4 is the current development version - it has some edge case bugs for sure but basic functionality is verified by our CI/CD pipeline. We are happy for everyone who is testing the development version and feed back any suggestions to us.