Cloudinit issues

Hi,

after a few weeks I want to generate me a new image.
But the see.iso is mounted. I see my set commands in the cloud-init.log after a few lines later, a see a message use fallback and I have a default vyos configuration that is useless for me.

latest version used.

sudo ansible-playbook qemu.yml -e disk_size=10 -e iso_local=/tmp/vyos.iso -e grub_console=kvm -e vyos_version=1.4.0 -e cloud_init=true -e cloud_init_ds=NoCloud

this is my minimal default set commands

Here is my user-data that is in my seed.iso

  - set firewall all-ping 'enable'
  - set interfaces ethernet eth0 address 'dhcp'
  - set interfaces loopback lo
  - set service https api keys id deploy key '715ed7617b48afbaeb52148c3a311311'
  - set service ntp allow-client
  - set service ntp server mytimeserver.org
  - set service ssh dynamic-protection
  - set service ssh port '22'
  - set system config-management commit-revisions '100'
  - set system conntrack modules ftp
  - set system conntrack modules h323
  - set system conntrack modules nfs
  - set system conntrack modules pptp
  - set system conntrack modules sip
  - set system conntrack modules sqlnet
  - set system conntrack modules tftp
  - set system host-name 'vyos-changeme'
  - set system login user vyos authentication encrypted-password '$6$bzNMRKNI4Dn3k8JD$NK7n9hv4dm5XQSGLB2/XL4hEvVjhiiqFgmegs52dFfx72C4czHUijWb6Zih7Ya15dWWYMUAV0afmcKW9uB6jQ/'
  - set system login user vyos authentication plaintext-password ''
  - set system login user vyos authentication public-keys deploykey key 'AAAAE2VjZHNhLXNoYTItbmlzdHA1MjEAAAAIbmlzdHA1MjEAAACFBABb3+MDj7SKmXfMKichf0gznZIKf/H5JoZkohyOEXbFxNZSlDkRkO4NCn0n6AmMNr65v2MvhNcJhsE7rOL/VjyVIABeLLvC/paYLkALHCc75MsUZx/wT8rX81FA7QQJxBL6d7xlyg73mt0gAlRNYnnCC6TUMaI+5+9W2Uw4auFbA9loFg=='
  - set system login user vyos authentication public-keys deploykey type 'ecdsa-sha2-nistp521'
  - set system name-server 'eth0'
  - set system syslog global facility all level 'info'
  - set system syslog global facility local7 level 'debug'

I read the the cloud-init.log but I found not really an error message.
I have tried the latest vyos version from today.