Commit fail after L2TPv3 interface configuration

l2tp

#1

I am new to VyOS and while learning, I’m trying to create an L2TPv3 interface on a VyOS VM, and I get this output :

vyos@vyos# sh interfaces l2tp
+l2tpv3 l2tpeth0 {

  • bridge-group {
  •    bridge br0
    
  • }
  • destination-port 10000
  • encapsulation udp
  • local-ip 172.31.31.2
  • peer-session-id 1
  • peer-tunnel-id 1
  • remote-ip 172.30.30.2
  • session-id 1
  • source-port 10000
  • tunnel-id 1
    +}
    [edit]
    vyos@vyos# commit
    [ interfaces l2tpv3 l2tpeth0 ]
    RTNETLINK answers: Network is unreachable
    RTNETLINK answers: No such device
    Cannot find device “l2tpeth0”

[[interfaces l2tpv3 l2tpeth0]] failed
Commit failed
[edit]
vyos@vyos#

Any ideas or help is appreciated!


#2

with version do you use?

show version

and can you post your running config?

show configuration

#3

show version:

vyos@vyos:~$ sh vers
Version:      VyOS 1.1.7
Description:  VyOS 1.1.7 (helium)
Copyright:    2016 VyOS maintainers and contributors
Built by:     maintainers@vyos.net
Built on:     Wed Feb 17 13:43:15 UTC 2016
Build ID:     1602171343-4459750
System type:  x86 32-bit Virtual
Boot via:     image
Hypervisor:   VMware
HW model:     VMware Virtual Platform
HW S/N:       VMware-56 4d 3e 79 40 5f 2f 66-bb 8c 59 5b 39 52 ab 88
HW UUID:      564D3E79-405F-2F66-BB8C-595B3952AB88
Uptime:       07:34:09 up  1:24,  3 users,  load average: 0.01, 0.04, 0.05

vyos@vyos:~$

show configuration:

vyos@vyos:~$ sh config
interfaces {
    bridge br0 {
        aging 300
        hello-time 2
        max-age 20
        priority 0
        stp false
    }
    ethernet eth0 {
        address 172.31.31.2/29
        duplex auto
        hw-id 00:0c:29:52:ab:88
        smp_affinity auto
        speed auto
    }
    ethernet eth1 {
        bridge-group {
            bridge br0
        }
        duplex auto
        hw-id 00:0c:29:52:ab:92
        smp_affinity auto
        speed auto
    }
    loopback lo {
    }
}
protocols {
    static {
        route 192.168.111.0/24 {
            next-hop 172.31.31.1 {
            }
        }
    }
}
service {
    ssh {
        port 22
    }
}
system {
    config-management {
        commit-revisions 20
    }
    console {
        device ttyS0 {
            speed 9600
        }
    }
    host-name vyos
    login {
        user vyos {
            authentication {
                encrypted-password ****************
                plaintext-password ****************
            }
            level admin
        }
    }
    ntp {
        server 0.pool.ntp.org {
        }
        server 1.pool.ntp.org {
        }
        server 2.pool.ntp.org {
        }
    }
    package {
        auto-sync 1
        repository community {
            components main
            distribution helium
            password ****************
            url http://packages.vyos.net/vyos
            username ""
        }
    }
    syslog {
        global {
            facility all {
                level notice
            }
            facility protocols {
                level debug
            }
        }
    }
    time-zone UTC
}
vyos@vyos:~$

The L2TPv3 configuration part was not saved.


#4

at 1st you should try a newer version. 1.1.7 is end of life.

Option 1 the Rolling Release:
https://downloads.vyos.io/?dir=rolling/current/amd64

Option 2 a version before the official 1.2.0 LTS release:
https://downloads.vyos.io/?dir=testing/1.2.0-rc11

or the last Option :slight_smile:
https://pages.vyos.io/access-subscriptions

In the config i notice, that you don’t have a route to your remote-ip 172.30.30.2?


closed #5

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.