Commit fails after OS upgrade to VyOS 1.1.3


#1

I am having issues after upgraded OS from VyOS 1.0.5 to VyOS 1.1.3

After upgrade to VyOS 1.1.3, I cannot do any modification and commit. As soon as I commit, I lost connectivity to vyatta and I had to reboot it. It come up fine with old configuration file ( config.boot )

Here are some messages I see when I enter in to config mode

vyatta@dwvyatta:~$ config
fuse: failed to open /dev/fuse: Permission denied

[edit]
vyatta@dwvyatta# exit
fusermount: entry for /opt/vyatta/config/tmp/new_config_3428 not found in /etc/mtab
exit
vyatta@dwvyatta:~$


#2

Are you using an image based (so install image to install) or a physical (install system) install for this system?


#3

I am using image based ( VyOS si installed in virtual machine )

installed new image as shown below.
add system image http://mirror.as62588.net/vyos/iso/release/1.1.3/vyos-1.1.3-amd64.iso

vyatta@dwvyatta:~$ show version
Version: VyOS 1.1.3
Description: VyOS 1.1.3 (helium)
Copyright: 2015 VyOS maintainers and contributors
Built by: maintainers@vyos.net
Built on: Wed Jan 28 14:11:52 UTC 2015
Build ID: 1501281411-ed1724a
System type: x86 64-bit
Boot via: image
Hypervisor: Xen hvm
Uptime: 07:59:33 up 0 min, 1 user, load average: 0.19, 0.05, 0.02

vyatta@dwvyatta:~$
vyatta@dwvyatta:~$ show system image
The system currently has the following image(s) installed:

1: 1.1.3 (default boot) (running image)
2: 1.0.5
3: Old-non-image-installation

vyatta@dwvyatta:~$

Here is the example. I tried creating a user and ran commit. Then I see following messages and lost my ssh connection to vyatta.

vyatta@dwvyatta:~$ config
fuse: failed to open /dev/fuse: Permission denied

[edit]
vyatta@dwvyatta# set system login user testuser full-name “Test User”

[edit]
vyatta@dwvyatta# commit
[ service ssh ]
Stopping OpenBSD Secure Shell server: sshd.

[ system ntp ]
Stopping NTP server: ntpd.

[ system syslog ]
Can’t use an undefined value as an ARRAY reference at /opt/vyatta/sbin/vyatta_update_syslog.pl line 96.

[ system package repository community ]
Removing entry from /etc/apt/sources.list…


#4

It Looks like the issue happens when we upgrade Vyatta from VyOS to VyOS ( as shown below )

Vyatta Core v6.6r1 -> VyOS v1.0.5 -> VyOS v1.1.3

If we upgrade from Vyatta Core v6.6r1 to VyOS v1.1.3, we don’t see this issue.


#5

Was this an image based of system install that you were upgrading from? I know you said the VyOS install was image based, I just wanted to check that it was an image based install through the whole upgrade. If you can let me know, then I can duplicate the process you’re going through and track down what’s causing it.


#6

Yes it is image based install.

Here is what I did

Upgraded from Core v6.6r1 to VyOS v1.0.5

Then upgraded from VyOS v1.0.5 to VyOS v1.1.3


#7

Good day.

Not working. I use ver 1.1.5

Problem is here:
vyos@dcgw01:~$ conf
fusermount: too many FUSE filesystems mounted; mount_max=N can be set in /etc/fuse.conf

[edit]


Why temp dir /opt/vyatta/config/tmp/

not cleared after commit & save - that’s normal ?


#8

Recently I tried Upgrade from vyatta Core >> VyOS 1.1.3 >> VyOS 1.1.5 and It did not show that issues. Could be problem with VyOS 1.0.5 ( I would need to re-test again )