Configuration system temporarily locked due to another commit in progress

Hi All

Im running 1.4-rolling-202201080317 as a kvm guest, which I rebooted in order to add an extra interface.
Post reboot, the boot sequence stops at

[ OK ] Reached target Login Prompts.
[ 26.708314] vyos-router[886]: Waiting for NICs to settle down: settled in 1sec…
[ 34.575662] vyos-router[999]: Started watchfrr.
[ 40.135526] vyos-router[886]: Mounting VyOS Config…done.

but I am able to ssh in after a few minutes.

I try to configure the new interface, only to see Configuration system temporarily locked due to another commit in progress when attempting to commit.
I found the processes, killed them, rebooted again, but this still occurs.

Please how do I fix this?

Can you share more information on how to reproduce this error? Router config, hypervisor, and steps.
Did you try with another vyos version?

No, I havent tried other versions.

vyOS is running in on a centos stream 8 kvm hypervisor.

I graphically added a new network interface on the vm using virt-manager, because the vm had run out of hot-pluggable pci slots, causing virsh attach-interface --domain vyos0 --type bridge --source br1005 --model virtio --config --live to fail with a No more available PCI slots error.

Rebooting is necessary after the new virtio network interface was added in order for the vyOS vm to see it.

I noticed after rebooting the boot sequence didnt end with the login prompt as it normally should, but I noticed other kvm guests using the vyOS vm as their router were able to communicate online so I tried ssh-ing in which worked.

Resolution:
I noticed from grep-ing the commit process (ps aux | grep [c]ommit and sudo systemctl status <PID>) that it was the vyos-router.service seemingly stuck on scp-ing some old config files in /tmp:

├─3244 /bin/run-parts --regex=^[a-zA-Z0-9._-]+$ – /etc/commit/post-hooks.d
├─3260 /usr/bin/perl /etc/commit/post-hooks.d/02vyatta-commit-push.pl
└─3265 python3 -c from vyos.remote import upload; upload("/tmp/config.boot.3260", "scp://user:password@:/home//config.boot-gw00.inf>

I deleted the tmp files, and rebooted, but same situation repeated itself. I noticed there were 3 config.boot files in /tmp, I have no idea if this is normal.
What fixed it was to restart the vyos-router.service and the boot process completes to the login prompt as before.

I do not have Centos for testing this.
I tried to reproduce this error, but had no success on other platforms, with different vyos versions. After adding new NIC, VM booted without troubles.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.