Containers/Podman - runroot error

Trying to deploy a bind slave on vyos as a secondary backup to the master hosted elsewhere.
However what ever container I deploy, regardless of how simple, I run into an error:

Failed to obtain podman configuration: runroot must be set

I tried copying and pasting the example from the docs and i get the same error.

Doing a little digging, if I run podman commands directly by calling podman on the CLI i’m able to interact with podman

vyos@Core-Router:~/podman/bind9/slave$ podman --version
podman version 4.3.1
vyos@Core-Router:~/podman/bind9/slave$ podman pull ubuntu/bind9:9.18-22.04_beta
Trying to pull
Getting image source signatures
Copying blob 453dc20a2d02 done
Copying blob 9e7b2fe80104 done
Copying blob 3d18cbd4c114 done
Copying config 7ae23a5b00 done
Writing manifest to image destination
Storing signatures
vyos@Core-Router:~/podman/bind9/slave$ podman image ls
REPOSITORY TAG IMAGE ID CREATED SIZE 9.18-22.04_beta 7ae23a5b00e8 47 hours ago 143 MB

However if i do this as root is also fails with the same error as the vyos config method:

sudo podman --version
Failed to obtain podman configuration: runroot must be set

I’m not very familiar with how vyos works under the hood. I notice the podman config in “/etc/containers/containers.conf” is generated by “/usr/libexec/vyos/conf_mode/”.
Editing containers.conf manually to add runroot gets overwritten when back in the vyos config setup.

Has anyone had this issue before? Any tips to help solve it or is it just a bug :frowning:

Versions tried:

VMware Workstation (labbing before bare metal deployment)

Hey Shrug, I posted last night here about the same thing :). Hope they fix soon.

In the meantime I can tell you that nightly 20230520 works fine w/ a container, at least for me.

Fixed via container: T5003: add new mandatory option runroot · vyos/vyos-1x@367423a · GitHub

1 Like

Thanks c-po! Will run a new build today to test :slight_smile:

@c-po Confirmed my container issue is resolved on a super fresh build with commit id: 4d0fac8c6e2bc5. Thanks for the fast fix!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.