Creating Vyos as Docker Container Fails with Error

The following packages have unmet dependencies:
vyatta-cfg : Depends: libvyatta-cfg1 (>= 0.102.0+vyos2+current4) but it is not going to be installed
vyos-1x : Depends: hvinfo but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
/tmp/vyos_install_stage_02.sh: line 47: /usr/share/vyos/version.json: No such file or directory
awk: line 2: function strftime never defined
awk: line 2: function systime never defined

Steps to recreate

Downloaded vyos-build

git clone -b current --single-branch https://github.com/vyos/vyos-build
cd vyos-build/vyos-docker

docker build --no-cache --pull --compress -f Dockerfile -t vyos:1.4-date -u +%Y%m%d%H%M%S --build-arg BUILD_DATE="date -u --rfc-3339=seconds" --build-arg VYOS_VERSION=1.4 --build-arg DEBIAN_VERSION=buster --progress plain …

I do not know what Iam doing wrong since ISO is created ok

Thanks

Hello, @akilos!
Thanks for the report and sorry for such a big delay with the answer. It was a bug that appeared after creating the new release train. It should be fixed in https://github.com/vyos/vyos-build/pull/144

We would be very grateful for testing images with 1.4.