Destination NAT not working?


#1

Hey guys, it’s my first post here so hello :slight_smile: Oh, and happy new year.

I’m having an issue trying to get RDP Dest NAT working to a specific computer through vyos.

So my config is this:

ISP router port forwarding 3389 to vyos on 192.168.1.101

vyos has 2 interfaces as below:

eth1 - 192.168.1.101
eth2 - 10.0.1.10

Server is on 10.0.1.21

Below is the config which looks right to me but it’s just not working, your help is much appreciated:

[code]vyos@vyOS# show
description RDP
destination {
address 10.0.1.21
port 3389
}

inbound-interface eth0
protocol tcp
source {
address 192.168.1.0/24
port 3389
}
translation {
address 10.0.1.10
}
[/code]


#2

Hello
you need to remove source from your dst. rule


#3

Hi, thanks but that didn’t work. :frowning:


#4

Ok so I fixed it and it works flawlessly, basically I had the rule completely screwed.

In case it helps anyone else I had to change to below, setting to listen on any interface and setting the translation address to where I wanted it to go, not destination address, destination address should be the address of the vyos router itself.

rule 5 { description RDP destination { address 192.168.1.101 port 3389 } inbound-interface any protocol tcp source { } translation { address 10.0.1.21 port 3389