DHCP client on ethernet interfaces not working in latest rolling release?

I’m running VyOS routers on a few different virtualization platforms which have a WAN address acquired via DHCP, and on the latest snapshot (vyos-1.4-rolling-202201291849-amd64.iso) I’m unable to get DHCP to work. At first I was concerned it was my configuration, but even on a fresh install of VyOS I’m unable to get a lease on an ethernet interface. The steps to reproduce are just:

  1. Install VyOS (vyos-1.4-rolling-202201270317)
  2. set interfaces ethernet eth0 address dhcp
  3. commit
  4. save

No address is acquired by eth0, even upon reboot. Switching to the previous rolling release (vyos-1.4-rolling-202201270317-amd64.iso) and performing the same steps results in a working DHCP client… so it seems to be a very recent development. I am testing the latest release on various virtualization platforms including VMWare ESXi and Virtualbox, but haven’t tried on any bare metal hardware.

Are other folks seeing this issue and is it appropriate to submit a bug report?



Hi Matt,

I saw the exact same thing with the that specific rolling version. Solved when I rolled back. Didn’t have time to reproduce and file a bug report but you are not alone :slight_smile:

I’m running on VyOS on KVM (Proxmox).

I did see some segfaults originating from the dhclient_script if you want to include that in the bug report.


Sure thing; I did find the segfault messages you were talking about. Writing the report, now!

1 Like

Phabricator task (@mshipman):

Bug is fixed
New iso is building,
will be available soon for download

Resolution confirmed!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.