Dhcp-relay to remote site via ipip tunnel


#1

Hi guys,

So I’ve started rolling out VyOS and IP in IP tunnels, to test the performance vs GRE tunnels. And there is a noticeable difference in the speed. Which is great!

[Back Story]
However, the test site, my office where I am located. We have users whom have left their PC’s on for a while, and when we pushed out the latest Windows 10 Feature Updates, they were restarted. Of course initially we thought that it was related to the Feature Update, but nope this was an issue else where.

[Issue]
Basically when we configured our dhcp-relay, using information that we have obtained across the interwebs and these forums.

  1. We configured the interface that was connected to the clients into a bridge port.
  2. We then proceeded to configure the dhcp-relay client as per the Wiki, specifying both the tunnel interface and also the bridge interface.
  3. Specified DHCP server.

So no DHCP packets seem to be passed onto the DHCP server and replied. No firewalls are currently configured at this stage.

[Configuration]

edit interfaces 
set bridge br0 address '10.2.100.254/24'

set ethernet eth3 bridge-group bridge 'br0'
set ethernet eth3 description 'uplink to VLAN100'
set ethernet eth3 duplex 'auto'
set ethernet eth3 hw-id '00:15:5d:64:0b:03'
set ethernet eth3 smp_affinity 'auto'
set ethernet eth3 speed 'auto'

edit service
set dhcp-relay interface 'tun0'
set dhcp-relay interface 'br0'
set dhcp-relay server '10.1.91.11'

Confused as hell! Because in a previous release of VyOS 1.1.7 I think or 1.1.6, it worked perfectly.

I read somewhere that someone got it working over tunnels. So would be good to know or find out what was done to get it working.


#2

On EdgeOS (another Vyata based platform) I gave up on using dhcp relay through tunnels.
My workaround is to use a switch that can do DHCP relay.

Also worth a try:
Build in DNS forwarder dnsmasq might also do dhcp relay.
config is like:

configure
delete service dhcp-relay
set service dns forwarding options dhcp-relay=10.1.91.11
commit


#3

@16again that’s exactly what I had done as well.