DHCP Server on eth1 on dual nic


#1

I am stuck creating DHCP Server for Eth1 on dual nic setup.
This is what I have so far…

configure
set system host-name GW-01
set interfaces ethernet eth0 address dhcp
set interfaces ethernet eth0 description External
set interfaces ethernet eth1 address 192.168.1.1/24
set interfaces ethernet eth1 description Internal
set service ssh

set protocols static route 0.0.0.0/0 next-hop 192.168.2.1
set nat source rule 5010 outbound-interface eth0
set nat source rule 5010 source address 192.168.1.0/24
set nat source rule 5010 translation address masquerade

set service dns forwarding name-server 1.1.1.1
set service dns forwarding cache-size 150
set service dns forwarding listen-on eth1

I dont know how to route the DHCP Sever to eth1 192.168.1.1 or even if its possible with the script so far.

commit
save
exit

Any help would be great-full thanks.
PlaceyAUS


#2

Hi
Please have a look here
https://support.vyos.io/en/guides/vyos-user-guide/user-guide/dhcp-server