Dhcpv6 on interface

I am having some strange issue with dhclient v6.
I am trying to configure interface for dhclient v6 using vyos command

‘set interface ethernet ethX address dhcpv6’

when I run this command , I loose previously assigned static ipv6 address on interface
moreover, I see configuration within vyos also removes ipv6 static address/s

Should it not support multiple Ipv6 address/s ?
so that I can have ipv6 address statically assigned as well as i can obtain from dhclient ?

does vyos do not support ipv6 address statically and dhclient at same time on same interface ???

any help will be appreciated…Thank you

Hi @nirmal
It is not possible to use both the static address and the address received via dhcp at the same time. The same is true for ipv4.

If you need multiple addresses on ethX interface, the only option is to use static addresses.

1 Like

Hi @Viacheslav
Thank you for quick response.

one more thing I have noticed is,

when I have configure interface for ipv6 autoconfig, and then tried to setup dhcpv6 on that interface I get vyos commit failed error.
I feel there is something in vyos which might be stopping me from configuring interface for dhcpv6 client when autoconfig is configured. I can do digging on scripts for nodes action but don`t know again whether its allowed from vyos point of view.

‘set interface ethernet ethX ipv6 disable-forwarding’
‘set interface ethernet ethX ipv6 address autoconfig’
works fine

‘set interface ethernet ethX address dhcpv6’
This commit fails…

Thank you

@nirmal Can you describe step by step? What version of the VyOS are you using?
More details about fail?

vyos@1.2-roll-ns# set interfaces ethernet eth1 address dhcpv6 
vyos@1.2-roll-ns# commit
vyos@1.2-roll-ns# run show interfaces ethernet eth1 brief 
Codes: S - State, L - Link, u - Up, D - Down, A - Admin Down
Interface        IP Address                        S/L  Description
---------        ----------                        ---  -----------
eth1             fd12:3456:789a:1::6/64            u/u

Sure @Viacheslav.

I am using VyOS 1.2.0-rolling+201807030337.

‘set interface ethernet eth2 ipv6 disable-forwarding’
‘set interface ethernet eth2 ipv6 address autoconfig’
(commit works fine: no error)

‘set interface ethernet eth2 address dhcpv6’
(commit Fails)

You can do above to reproduce the problem.


Hi @nirmal can you try more modern rolling version?

vyos@R1# set interface ethernet eth2 ipv6 disable-forwarding 
vyos@R1# set interface ethernet eth2 ipv6 address autoconf 
vyos@R1# commit
[ interfaces ethernet eth2 ipv6 disable-forwarding ]
Disabling IPv6 forwarding for eth2

[ interfaces ethernet eth2 ipv6 address autoconf ]
Enabling address auto-configuration for eth2

vyos@R1# set interface ethernet eth2 address dhcpv6 
vyos@R1# commit

hi @Dmitry,

I can confirm that above set of commands works fine on latest release.

But unfortunately, I can not update my vyos version as of now.
Would you tell me any source code changes that I can lookup to find solution ??

I also have other strange issue with dhcpv6 is when I enable this on interface and restart my machine, on bootup I loose all VYOS config related to that interface.
Although, interface do exists as I can see it when i do ifconfig command.
But within VYOS nothing exists for that interface.

for example if I do following and reboot

vyos@R1# set interface ethernet eth2 address dhcpv6 
vyos@R1# commit

After reboot vyos will show noting in its config for interface ethernet eth2
but I do have interface eth2 on system, as I can see it in ifconfig command output


Sorry, exist many changes from rolling 20180703 to lates. You can try to search by yourself in git repo or look in to boot log files.

cat /var/log/vyatta/vyatta-config-loader.log
cat /var/log/vyatta/vyatta-commit.log