disable redirects


#1

In my relative simple setup, i saw the following in dmesg on the command prompt:

[quote]IPv4: Redirect from 92.56.120.61 on eth1 about 92.56.120.62 ignored
Advised path = 173.[my.ip.address] -> 0.0.0.0
[/quote]

Ip redirect is part of the network layer:
Internet Control Message Protocol (ICMP)
http://en.wikipedia.org/wiki/Internet_Control_Message_Protocol#Redirect

There is a nice firewall rule to force ignoring ip redirects.

[quote]set firewall receive-redirects disable
set firewall send-redirects disable[/quote]
After that of course commit & save to apply the rule and make sure it is loaded next time the router is booted.

BTW: This also works on vyatta & edgeos.