Do the bond interface works for mpls forwarding?

Hello all,

Could anybody know - do the bond interface should work for mpls?
I mean bond interface as mpls interface, like this:

“set protocols mpls interface bond1”

I had strange thing: I configured bond as mpls interfaces a week ago, and this is worked.
Worked - I mean traffic passed between dummy in vrf in two vyos-routers.
But in some moment it is stopped work.
Pings between dummy dont work but these vpnv4 prefixes exchange is happens successfull. I see ICMP-request in monitor traffic interface bond on that vyos from what I sent pings. But on the other end I dont see these ICMP-requests.
So seems forwarding plane is broken by some reasons.

If I turn back config for mpls interface as eth2-interface - mpls (and forwarding) starts to work.

Thanks in advance

P.S.
show version:

admin@vyos-lns-1:~$ sho version

Version: VyOS 1.4-rolling-202204261551
Release train: sagitta

Built by: alexander.serkin@gmail.com
Built on: Tue 26 Apr 2022 15:51 UTC
Build UUID: 7cf6d95e-f545-4018-bb90-52af837248cd
Build commit ID: cb4ce6caf048aa

Architecture: x86_64
Boot via: installed image
System type: VMware guest

Hardware vendor: VMware, Inc.
Hardware model: VMware Virtual Platform
Hardware S/N: VMware-42 3f cb af f2 a1 a7 90-63 10 a4 41 68 d9 8d 43
Hardware UUID: 423fcbaf-f2a1-a790-6310-a44168d98d43

Copyright: VyOS maintainers and contributors
admin@vyos-lns-1:~$

it should work on Bond interfaces. However, it seems that lsp was broken for some reason on LAG interfaces .also, this behavior can be occasional by virtual interfaces and bond, what type of interface are you using? on vmware.

Note

If you happen to run this in a virtual environment like by EVE-NG you need to ensure your VyOS NIC is set to use the e1000 driver. Using the default virtio-net-pci or the vmxnet3 driver will not work. ICMP messages will not be properly processed. They are visible on the virtual wire but will not make it fully up the networking stack.


https://docs.vyos.io/en/latest/configuration/interfaces/bonding.html#example