does "use-web" actually work (dynamic dns)


#1

I’m looking at the docs for using dynamic dns (http://vyos.net/wiki/Dynamic_DNS#ddclient_behind_NAT), and they say to use the following command if your interface doesn’t have a public ip:

Does this actually work? I’m using 1.1.7, and it doesn’t appear to be a valid command. Any ideas?

Thanks!
Justin


#2

what are you trying to do?

Has to be entered with url behind it like:

this is just an example though, that url is invalid.


#3

Thanks for the reply.

My vyos router has a private IP, and I need to publish my public IP. As far as I can tell, that’s the only option.

I see the mistake I made. I thought that the string “url” was meant to be replaced by the actual url. I was doing this:

I’ll try that when I get home. I did try to tab through the options, and “use-web” didn’t come up. So we’ll see!


#4

Nope, doesn’t work! Is there anything I’m missing here?

[code]vyos@vyos# set service dns dynamic interface eth1 use-web url api.ipify.org

Configuration path: service dns dynamic interface eth1 [use-web] is not valid
Set failed[/code]