Equivalent Cisco IOS configuration for VLAN with Traffic shaping

Can someone point me in the right direction with doing the equivalent of the Cisco IOS Config below? We have an ATT ASEoD connection from our main site to two remote sites via two VLANs. I need to restrict the one VLAN to 100Mb and the other to 250Mb. We need to give priority to voice traffic. This is what we use now. Thank you.

class-map match-any VOICE-TRAFFIC
match access-group name ACL-VOICE
match ip dscp ef
class-map match-any VIDEO
match ip dscp af41
class-map match-any VOICE-SIGNAL
match ip dscp cs3
match ip dscp af31
match ip dscp ef
!
policy-map QOS-POLICY
class VOICE-TRAFFIC
priority percent 30
class VOICE-SIGNAL
bandwidth percent 5
class VIDEO
bandwidth percent 25
class class-default
random-detect
policy-map ASE-250M
class class-default
shape average 235000000 2350000 0
service-policy QOS-POLICY
policy-map ASE-100M
class class-default
shape average 95000000 950000 0
service-policy QOS-POLICY
!
!
interface GigabitEthernet0/0/0
description LAN
ip address 10.1.11.254 255.255.0.0
negotiation auto
no mop enabled
!
interface GigabitEthernet0/0/1
description ASE Ckt
no ip address
speed 1000
no negotiation auto
!
interface GigabitEthernet0/0/1.601
description CT 601
encapsulation dot1Q 601
ip address 192.168.110.1 255.255.255.252
service-policy output ASE-100M
!
interface GigabitEthernet0/0/1.602
description CL 602
encapsulation dot1Q 602
ip address 192.168.100.1 255.255.255.252
service-policy output ASE-250M
!
interface GigabitEthernet0/0/1.603
description SHC 603
encapsulation dot1Q 603
ip address 192.168.128.1 255.255.255.252
service-policy output ASE-100M
!

Hi @psmith , I think you can try to use something like this for 100M shaper and create similar for 250M:

set traffic-policy shaper ASE-100M bandwidth '100mbit'
set traffic-policy shaper ASE-100M class 10 bandwidth '30%'
set traffic-policy shaper ASE-100M class 10 description 'VOICE-TRAFFIC'
set traffic-policy shaper ASE-100M class 10 match voip ip dscp 'EF'
set traffic-policy shaper ASE-100M class 10 match voip ip protocol 'udp'  **# Replace with your protocol**
set traffic-policy shaper ASE-100M class 10 match voip ip source address '192.168.255.0/24'  **# Replace with your ip source or destination subnet**
set traffic-policy shaper ASE-100M class 10 match voip ip source port '5060'  **# Replace with your specific port**
set traffic-policy shaper ASE-100M class 10 priority '1'
set traffic-policy shaper ASE-100M class 10 queue-type 'priority'
set traffic-policy shaper ASE-100M class 20 bandwidth '5%'
set traffic-policy shaper ASE-100M class 20 description 'VOICE-SIGNAL'
set traffic-policy shaper ASE-100M class 20 match voip-signal ip dscp 'AF41'
set traffic-policy shaper ASE-100M class 20 priority '0'
set traffic-policy shaper ASE-100M class 20 queue-type 'priority'
set traffic-policy shaper ASE-100M class 30 bandwidth '25%'
set traffic-policy shaper ASE-100M class 30 description 'VIDEO'
set traffic-policy shaper ASE-100M class 30 match video-ef ip dscp 'EF'
set traffic-policy shaper ASE-100M class 30 match video-af31 ip dscp 'AF31'
set traffic-policy shaper ASE-100M class 30 match video-cs3 ip dscp 'CS3'
set traffic-policy shaper ASE-100M class 30 priority '3'
set traffic-policy shaper ASE-100M class 30 queue-type 'priority'
set traffic-policy shaper ASE-100M default bandwidth '10%'
set traffic-policy shaper ASE-100M default ceiling '100%'
set traffic-policy shaper ASE-100M default priority '7'
set traffic-policy shaper ASE-100M default queue-type 'random-detect'

set interfaces ethernet eth1 vif 603 traffic-policy out 'ASE-1M'  **# Replace with your interface and vlan-id**