Error building from source

Hi everyone!

I’m trying to build vyos using the dockerfile following the directions from https://github.com/vyos/vyos-build/blob/current/README.md. Everything runs fine, except the make iso command.

This is the error that I’m facing:

Checking build configuration
[2019-06-05 17:14:52] lb clean
P: Cleaning chroot
Starting VyOS ISO image build
Setting up additional APT entries
Configuring live-build
[2019-06-05 17:14:52] lb config noauto --architectures amd64 --bootappend-live boot=live components hostname=vyos username=live nopersistence noautologin nonetworking union=overlay --linux-flavours amd64-vyos --linux-packages linux-image-4.19.32 --bootloader syslinux,grub-efi --binary-images iso-hybrid --debian-installer false --distribution jessie --iso-application VyOS --iso-publisher aldemaro@aldemaro.com.br --iso-volume VyOS --debootstrap-options --variant=minbase --exclude=isc-dhcp-client,isc-dhcp-common,ifupdown --include=apt-transport-https --mirror-bootstrap http://deb.debian.org/debian --mirror-chroot http://deb.debian.org/debian --mirror-chroot-security http://deb.debian.org/debian-security --mirror-binary http://deb.debian.org/debian --mirror-binary-security http://deb.debian.org/debian-security --archive-areas main contrib non-free --firmware-chroot false --firmware-binary false --updates false --security true --apt-options --yes -oAcquire::Check-Valid-Until=false --apt-indices false
P: Updating config tree for a debian/jessie/amd64 system
P: Symlinking hooks...
Traceback (most recent call last):
  File "scripts/make-version-file", line 49, in <module>
    repo = git.Repo('.')
  File "/usr/lib/python3/dist-packages/git/repo/base.py", line 156, in __init__
    raise InvalidGitRepositoryError(epath)
git.exc.InvalidGitRepositoryError: /root/vyos-build-crux
Makefile:14: recipe for target 'prepare' failed
make: *** [prepare] Error 1

Am I doing something wrong or is it a bug?

I tried to build using a bare metal server using Centos 7, Debian 8 and using a VM and got the same error.

This is the same issue as here: https://phabricator.vyos.net/T1427

Please compile using the docker method, then you dont need a debian as a base and dont need to manage dependencies manually

Thank you for the reply.

Looks like it works when you clone the repo, but not when you download.

Is it the expected behavior?