Error on adding a wireguard interface to OSPFv3

i have OSPF (ipv4) up and running with some ipsec-vti (+ neighbor’s) and wireguard (passive) interfaces
this is working fine.

now i’m trying to add OSPFv3 (IPv6) to it.
this works with de VTI interfaces:

XXX@rt01# show protocols ospfv3 | strip-private 
 area {
     range xxxx:xxxx:c2c:2bd9::/64 {
     range xxxx:xxxx:fd32::/48 {
 interface lo {
 interface vti101 {
     network point-to-point
 interface vti201 {
     network point-to-point
 interface vti202 {
     network point-to-point
 interface vti203 {
     network point-to-point
 log-adjacency-changes {
 parameters {

but when i’m trying to add the wireguard interfaces i’m getting the following error:

rt01# compare 
[protocols ospfv3 interface]
+ wg231 {
+     area ""
+     passive
+ }

XXX@rt01# commit
[ protocols ospfv3 ]
VyOS had an issue completing a command.

We are sorry that you encountered a problem while using VyOS.
There are a few things you can do to help us (and yourself):
- Contact us using the online help desk if you have a subscription:
- Make sure you are running the latest version of VyOS available at:
- Consult the community forum to see how to handle this issue:
- Join us on Slack where our users exchange help and advice:

When reporting problems, please include as much information as possible:
- do not obfuscate any data (feel free to contact us privately if your 
  business policy requires it)
- and include all the information presented below

Report time:      2024-01-28 21:41:14
Image version:    VyOS 1.5-rolling-202401090834
Release train:    current

Built by:
Built on:         Tue 09 Jan 2024 10:30 UTC
Build UUID:       350f1f79-e581-4dd2-956c-36b7ef1c5e5c
Build commit ID:  92195009af863c

Architecture:     x86_64
Boot via:         installed image
System type:      KVM guest

Hardware vendor:  Hetzner
Hardware model:   vServer
Hardware S/N:     14585311
Hardware UUID:    156eed2a-0020-4471-ad82-eecfe5de4127

Traceback (most recent call last):
  File "/usr/libexec/vyos/conf_mode/", line 184, in <module>
  File "/usr/libexec/vyos/conf_mode/", line 175, in apply
  File "/usr/lib/python3/dist-packages/vyos/", line 482, in commit_configuration
    raise ConfigurationNotValid(f'Config commit retry counter ({count_max}) exceeded for {daemon} dameon!')
vyos.frr.ConfigurationNotValid: Config commit retry counter (5) exceeded for ospf6d dameon!

[[protocols ospfv3]] failed
Commit failed

What gone wrong here?

Hi @Spookje - welcome to the Vyos forums.

You haven’t mentioned which version of Vyos you’re using, but regardless it sounds like you’ve hit a fairly concrete bug.

If you’re able, it would be great if you could write up the details on the page. But if you really don’t feel like doing that (you’ll need to create an account there if you don’t have one), please post as much detail here as you’re able, especially what version(s) you’ve tried and if any of them worked, and I or someone else can write up a ticket on your behalf.

Thanks for reporting it though!


Hi Tim,

The version was in the VyOS error report, that is why I skipped it:

Image version:    VyOS 1.5-rolling-202401090834

I do have an account, so I will make an issue there.

Fixed in latest 1.5 rolling release and upcoming 1.4.0-epa1 release.

1 Like