Erroring when building 1.3.1

Hey All,
I am trying to build VyOS LTS 1.3.1 from the zip file on github, but am getting the below error message. This happens on a raw debian Buster build, or the container pulled from dockerhub. The latest rolling release builds without issue.

I can’t seem to find much on the issue through Google, but from the surrounding commands, it appears to be from 17-gen_initramfs.chroot. The -k option is specified, so the command should in theory run without issue. Does anyone have any suggestions on what to look at for this?

Processing triggers for systemd (241-7~deb10u8) ...
I: Create initramfs if it does not exist.
Extra argument '5.4.191-amd64-vyos'


Usage: update-initramfs {-c|-d|-u} [-k version] [-v] [-b directory]

Options:
 -k version     Specify kernel version or 'all'
 -c             Create a new initramfs
 -u             Update an existing initramfs
 -d             Remove an existing initramfs
 -b directory   Set alternate boot directory
 -v             Be verbose

See update-initramfs(8) for further details.

E: config/hooks/live/17-gen_initramfs.chroot failed (exit non-zero). You should check for errors.

Hi Antleo,

Have you tried the method of building your VyOS image described in our documentation?
https://docs.vyos.io/en/equuleus/contributing/build-vyos.html#

Hey Nikolay,

Yes, I tried both using the native build method, and the dockerhub method. The only step I did differently was instead of git clone -b equuleus --single-branch https://github.com/vyos/vyos-build I did wget https://github.com/vyos/vyos-build/archive/refs/tags/1.3.1.zip unzipped it and ran everything from within that file (instead of the cloned repo)