Ethernet iface names changed after reboot

Hehey Folks

I’m running in a very disgusting problem, after a fresh install on a supermicro, i did the settings for the lan interface (eth2).

I did a reboot and now the “LAN iface” is now eth1… ok i delete the eth2 settings and did the settings on eth1, i don’t trust this anymore and so i did a reboot one more time… holy s**t … now it is eth3 …

I have 2 on-board eth interfaces and 2 on my pci nic, i never change the cable but the system change the eth(number) after every reboot.

sometimes the 1, sometimes the 3 and sometimes the 2… but never the 0, or i did not enough rebootings. :slight_smile:

This is absolutely not ok and i use roling release, and my question is; is that a way to static-mapping the MAC to eth(number).

I can’t play russian-lan-roulet on a important network device. :wink:

warm regards.

Hi @yog .
You can set in config file mac interfaces.
For example, if you have 4 eth interfaces. you may try something like this.

First, take note of mac address of your devices. Then, delete and assigned mac address again:

delete interfaces ethernet eth0 hw-id
delete interfaces ethernet eth1 hw-id
delete interfaces ethernet eth2 hw-id
delete interfaces ethernet eth3 hw-id

set interfaces ethernet eth0 hw-id xx:xx:xx:xx:xx:01 
set interfaces ethernet eth1 hw-id xx:xx:xx:xx:xx:02 
set interfaces ethernet eth2 hw-id xx:xx:xx:xx:xx:03
set interfaces ethernet eth3 hw-id xx:xx:xx:xx:xx:04 

Then commit, save, and reboot.

1 Like

mhhh this solution is such logic, but no success, the eth* is still on a random trip.

i was on at my router, cause… ssh is not possible on this random interfaces. :wink: i check the mac addesses, they are all the same, so there is no “mac-changer” in the background.

Do NICs really have identical MAC addresses? That seems like faulty hardware to me.
If other OSes can handle this, it’s because they identify NICs by internal hardware ID (bus/slot number)

1 Like

Hehey, sorry for the delay.
I did a new fresh install and my first step was to static mapping the MAC to Interfaces and now it works like a charm. This is a little option, but for me, a very powerfull option and after 12 or 14 reboot, they are stable, with and without ip/ipv6 and pppoe settings.

thanks for the help and warm regards.

yog / andi

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.