Handle Interface assignment after manuell copy vyos VM to another ESX Host


#1

Hello,

i run an vyos 1.2.0 EPA2 in a standalone ESX host. Now i want to change the Hardware. I export the VM on the old ESX to an OVF file and import it on the new Hardware.

In vyos i have 4 Interfaces (eth0-3)

After the import the i have interfaces eth4-7. I manuelll delete the hw-id entrys in the config.boot file.
Now i have eth0 eth2 eth3 eth4.

eth0, 2, 3 are working fine, but i don’t get eth1 back to work.

What can i do?


#2

i tryed a recommendation from steve from the Slack channel. and set the correct hw-id to eth1 in config.boot

But this don’t worked


#3

Hi, @robort!
So, you set correct hw-id for eth1, reboot and interface is not configuring after this according to config file?


#4

Today I restarted, deleted the imported VM and reimported the VM. After booting, no interface was set correctly. Then I delete all hw-id entries in the config.boot file. Restarted the system. And now it worked. This was the same procedure as yesterday. But yesterday eth1 was missing and always assigned as eth4. I don’t know what went wrong yesterday.


closed #5

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.